Re: Chrome thinks every field is a password field and offers to create or save the password

1985 3
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Chrome has started thinking every field in Airtable is a password field and pops up the 'Do you want to save this password?' after I finish typing in any field. It is very annoying!

It is also preventing me from choosing a date in a date field because it pops up the 'create a strong password' right on top of the calendar and I can't click on anything!

I've tried Googling for instructions for how to block the password autofill/offer to save on just one site, but can't find instructions exactly. 

Is anyone else having this issue? As far as I know, I didn't change anything about Chrome, this just started happening. 

59 Replies 59
5 - Automation Enthusiast
5 - Automation Enthusiast

This is not a chrome issue. it is happening to me in many browsers and operating systems. While the data view seems to be resolved today, I am still getting an issue with the interfaces. I have a filter at top that normally stays blank but it now autofills my email address into this unrelated filter. This then filters out all the records.

This wasn't happening 2 days ago. Now it happens on each field unless I change from single line text to long line.  Thanks for the suggestion

7 - App Architect
7 - App Architect

Actually glad to see it ISN'T just me! This is really very disruptive!

5 - Automation Enthusiast
5 - Automation Enthusiast

Just adding my voice here in hopes that I'll get notified when there is a solution to this problem. I've tried to contact support and can't seem to do so anymore - I just get sent around in circles by a bot. This issue's making it really hard to work in Airtable! 

this fixed it for me, too, but I hope they fix it for real sometime soon!

4 - Data Explorer
4 - Data Explorer

Also adding my voice to say how annoying it is! I too use Chrome's password manager too often for that to be a convenient workaround and the turning off the 'experiment' didn't work for me. Hope they find a solution as it's becoming too frustrating to use!

6 - Interface Innovator
6 - Interface Innovator

Not sure if this has been mentioned before, but here's our workaround in case it's helpful:

In Chrome disable passwords just for  Chrome won't offer to remember them for airtable, but still will for everything else. 

To log into airtable without a password, use the "sign in with Google" option if it's available to you.  If it's not, at least airtable is the only site that will require a manual login.  

4 - Data Explorer
4 - Data Explorer

Hello! I found a solution! If you go to your Google Password Manager, then to Settings, turn off "Offer to Save Passwords."

Unfortunately, this also disables the pop-up to save a password when you're actually logging into something. So, you'll have to go to Passwords Manager, then Passwords, and click "Add" if you want to save a new password. Or turn it off if you're working in Airtable for awhile and turn it back on when you're done.

You can get to Password Manager by clicking the 3 dots in the top right of Chrome, then click "Passwords and Autofill," the click "Google Password Manager."

How are you turning off passwords for just airtable? I use "sign in with Google" for my airtable login, but use the password manager on too many other things to fully disable it, as the workaround suggests - but if I can specify it for just airtable, maybe this can stop happening!

Here's what we did (Windows 10):

  1. Click the three dots in the upper right corner of the Chrome window
  2. Passwords and autofill
  3. Google Password manager
  4. Search for "airtable" and click on the record that comes up
  5. Enter Windows password 
  6. Click delete
  7. Go back to an airtable grid view
  8. Enter some text in a blank cell (ignore the popup to generate a random password if it appears)
  9. Click another cell to save the text in the airtable cell
  10. Hopefully there's a popup offering to save that password in Chrome
  11. Click "Never"

Maybe there's a simpler way, but that worked for us.  Good luck!

This didn't work for me. Instead it just crashed / reset all my chrome browsers and some of my apps and then continued to ask me for the password. So don't recommend the EXPERIMENTS disable solution.

4 - Data Explorer
4 - Data Explorer

The best solution I found for now if you use Airtable heavily is turning off Chrome offering to save passwords:

1. Go to your chrome passwords manager:

2. Click the settings cog.

3. Turn off "Offer to Save Passwords"

Obviously this affects your future ability to save passwords but you can turn it back on once you're done with Airtable, or keep it off while the Airtable team fixes.

4 - Data Explorer
4 - Data Explorer

did not work for me either!

This worked perfectly for me. Thanks!

5 - Automation Enthusiast
5 - Automation Enthusiast

This is great - worked for me without having to turn off Google's password saving function (which is really useful, usually). Thanks! 

Airtable Employee
Airtable Employee

Hey all, we've made a few fixes to help stop this from happening.

If you still see this issue happening, please update Chrome to the latest version.

If after updating Chrome you still see this problem, please help us keep investigating by telling us:

  1. What version of Chrome you are using
  2. What part of the product you are using (e.g. Grid view, not in an Interface)
  3. What input fields the autofill is mistakenly appearing in

We're sorry about this annoying issue - we'll keep trying to fix it!

6 - Interface Innovator
6 - Interface Innovator

This issue appears to now be fully resolved for me [using Chrome Version 119.0.6045.123 (Official Build) (64-bit) on Windows]!  YAY!!!  Thanks David and the AirTable team!

This just started occurring again today. It was fixed until now. I also wanted to mention that our GM uses Safari on a Mac and experiencing the same issue. 😞 Bummer

  1. Versión 120.0.6099.109 (Build oficial) (arm64)
  2. Grid view
  3. Multiple select, but not only

@Samir_Ghosh I already reported this but the issue has returned as of about a month ago. It's persistent and happens many many times a day. It was fixed for a short while when you reported this but this is SUPER frustrating and in the way of our every day work. Please advise.