Help

Re: remoteFetchAsync not working

Solved
Jump to Solution
2957 1
cancel
Showing results for 
Search instead for 
Did you mean: 
wheels_2go
4 - Data Explorer
4 - Data Explorer

Today any script that I was using remoteFetchAsync (to avoid CORS errors) is giving me this error:

 j: Error: Bad request: <root>.requestJson is missing

This error comes up on a few requests to different unrelated APIs. Additionally, some which work using regular fetch give this error when using remoteFetchAsync.

These scripts were working fine until now. Any ideas?

46 Replies 46
Greg_Lhotellier
5 - Automation Enthusiast
5 - Automation Enthusiast

Replacing removeFetchAsync with fetch worked for me as well! 🙌

Thanks @rudrava 😊

NirT
4 - Data Explorer
4 - Data Explorer

@quyvo wrote:

I tried to use a bypass CORS extension (e.g https://chrome.google.com/webstore/detail/allow-cors-access-control/lhobafahddgcelffkeicbaginigeejlf) (or enable CORS on API server), then update the script to use fetch instead of remoteFetchAsync. This is a workaround solution while waiting for AirTable to fix this.


^^^^^

@quyvo's temporary workaround will work for most cases if you only need to test your script, there are some services that will still block you although you are using fetch and the allow cors chrome plugin is on (I have a gcloud run service that I can get the workaround to work and fetch the data from but when I need to make another call to a gcloud function I still get an error).

Did anyone hear from Airtable's support? currently still waiting for an answer about the issue.

 

**** Update

Airtable support responded:

Hi there,

 

We’re incredibly sorry for the trouble - Airtable is currently experiencing problems with its API, and our engineers are actively working on the issue. We know that you rely on Airtable, and we sincerely apologize for the disruption that this issue is causing you.

 

We will be in touch as soon as we have any updates! Thanks so much for your patience.

 

Best,

The Airtable Support Team

Breight_Group
6 - Interface Innovator
6 - Interface Innovator

Please Fix ASAP, this is causing business critcal errors

GILSupport
4 - Data Explorer
4 - Data Explorer

Same here. Our workflow is interrupted and causing major havoc.

siriwat
6 - Interface Innovator
6 - Interface Innovator

I found people in this threads are facing the same problem, but the work around can be done based on your environment.

Case 1. remoteFetchAsync was inside your automation script. Here you can switch from remoteFetchAsync to fetch, then it will be solved.

Case 2. remoteFetchAsync was inside your extension script. In this case, the script will be run using a browser, so you will still not be able to switch to fetch as and Airtable frontend still block you with CORS related issue. So, you will need to migrate your extension script to automation script.

Case 2 How?

You will need to create an automation trigger e.g. when a record is updated (maybe a check box) -> then run your migrated script. Also, if you need inputs, you need to change input.recordAsync() to input.config()

Well, this way solves the problem on my side completely.

 

But wait?? why we need to do these ourselves?

Airtable Support team please wakeup, your morning is burning!! 😅

Hugo_Lancel1
4 - Data Explorer
4 - Data Explorer

Having the same critical issue here.

Your a legend! We are back up.

Thank you siriwat.

Jessy_Hu
Airtable Employee
Airtable Employee

Hey everyone, we wanted to acknowledge that the team is aware of the error when using RemoteFetchAsync() and are currently investigating the issue. We apologize for the inconvenience that this may have caused and hope to have more information to provide soon.

Thank you Jessy, I greatly appreciate your acknowledgment of the error. 

Many thanks, 

Mauro 

Jean_Thoensen
6 - Interface Innovator
6 - Interface Innovator

We have a time critical email we need to send to 500+ users via the SendGrid extension right now. What is the ETA for this?