Attachments: Ability to paste (cmd + v) a screen shot into the field from my clipboard


#1

Would like the ability to past a screen shot into the attachments field.

Use case: If I am tracking visual changes to design project I can easily paste in a visual reference for the change.


#2

You can already paste directly from the clipboard into the expanded upload attachments screen:


#3

Okay great. Didn’t investigate enough… thanks Katherine!


#4

Please add the feature to allow pasting without having to open the attachment screen.

Currently if you CTRL-V in the table with a picture in the clipboard, it says “nothing to paste”.

For example in Trello, you could paste when a card is open or when card is closed and the cursor is over a particular card in the list and press CTRL-V to paste the image into that card.

This would be really useful in Airtable IMO. Thanks.


#5

Yes, this wasn’t clear. RIght now you actually have to click the expanded window first before pasting. If you just open up the expanded window and paste, it won’t register. However, if you click the background (e.g., where the ‘Drag files here’ note is) first and then Command/Control + V, it’ll upload. I was about to request this feature myself until I found this thread.

However, it would be create to be able to do this at the cell level without expanding the window.


#6

David, I can’t seem to get this workaround to work for me. Nothing seems to be pasting?


#7

I’m able to get this working both on the Web (using Chrome) and the Airtable desktop app for Mac. When you open the attachment screen, click the gray background (you have to click the background first, presumably to give it focus). Then paste an already copied image (e.g., from a screen clipper) using Command + V (or Ctlr + V on a PC, presumably) and it should paste it in. Once pasted, you can Upload it or use the ‘Convert’ button to edit the image. See screenshots below.

Now what Airtable could/should do is put a ‘Paste from Clipboard’ option directly in the left sidebar (e.g., right after My Computer) to make this obvious and readily accessible!


#8

I’m using chrome with a chromebook. I tried the method above and it does not work for me.
+1 the idea of being able to simply copy and paste into the attachment column rather than having to open the attachment screen


#9

I am a new user piloting AirTable as a method of issue tracking for a mid-size PD firm.

Echoing that the current workflow of adding an image (3 clicks required) is too cumbersome.

AirTable team, simplifying this to a simple field selection + Ctrl-+V would be a welcome improvement!


#10

@Katherine_Duh, the recent updates to the attachments UI broke this functionality. Even the janky method that I used to use to paste from the clipboard no longer works, and this very frustrating. My primary use case is copying screen captures as references or examples, and now I can’t even seem to use the previous method.

Once again, I would very highly recommend adding a “Paste from Clipboard” option or button directly in the UI, or if that can’t be done, at least provide the awkward workaround method that previously was available.

In short, the recent update made Attachment fields less useful and usable. As a big Airtable proponent, I and several other of my colleagues are VERY disappointed.


#11

Hi @David_Krizan:

You should be able to paste into the attachments UI by clicking the header (where it says “My Device”) and pressing Cmd/Ctrl + V.

Let me know if that doesn’t work for you!


#12

Hi @Stephen_Suen, no it’s definitely not working for me on the Mac desktop app (latest version). I’ve tried 100+ times and I just tried at least a dozen times more just now. I’m using Mac OS Mojave.

However, it is still working on the Web App.


#13

@Stephen_Suen It’s been nearly a month, any updates on this? This has been very annoying, as the last big updated REMOVED this very useful functionality from the Mac desktop app. Now whenever I want to post a screen capture to an Attachment field, I have to stop what I’m doing in the desktop app, open up a web browser, locate the particular record, and then do in the web app what I previously was able to do in the desktop app rather simply. This is very disruptive and to be completely frank, yes, this just really sucks…


#14

Hi David,

Thanks for your patience. This should be fixed in the desktop app now.


#15

Thanks @Kasra, I’m very happy to see this work again! :slight_smile: I previously had to open up the given record in a web browser and paste in a screen capture from there, which was very cumbersome.