Disable "create new option named..."

When you start typing in a single or multiple select field, a drop-down appears that shows matching options, or allows you to enter a new option.

Obviously this is super useful–the problem is, the behavior of the “enter” key is ambiguous in this context. In the attached screenshot, you can see that if I want to select “ASAP” here, all I need to do is type “as” and press enter or tab. But sometimes this instead adds a new option named “as.” This happens to me almost constantly, and it’s… kind of infuriating. I have to fix the record itself, then go into “customize field type” to delete the “as” option.

I’m guessing what’s happening is that “create a new option” is loading more quickly than the match results do? In which case maybe just making sure it doesn’t appear until all potential matches have been checked might solve the problem. But another option that might have additional benefits would be to lock the options so that you can’t add a new option without going into the “customize field type” menu.



The “editor” level of permissions doesn’t have the ability to add new options to single-select and multiple-select fields, so if you log in as an editor, you won’t be able to add new options.

BTW, FWIW: I’ve never had that problem where Airtable chooses the “create a new option” item on accident. No matter how quickly I type the first letter (or two) and then press return extremely quickly afterwards, it always selects the right option. Even in an extremely large table with 25,000 records, it is always instantaneous for me and always chooses the right option — no matter how quickly I type the first letter and no matter how quickly I press return immediately afterwards. Sometimes it’s so quick that I don’t even see the list of options appear at all.

Hmm, that’s strange. I double-checked this in creating this post and again just now to confirm that I wasn’t missing something. The only difference I noticed is that right now at least, it actually doesn’t matter how quickly I do this–it ALWAYS creates a new entry. In order to use the keyboard to do this, I have to either use the arrow keys to select the proper entry, or type out the full name of the option I’m trying to select.

I wonder if Airtable has somehow “learned” that I choose this option often (albeit accidentally) and now assumes that’s what I want to do? I’m not sure what I’m missing.

As far as I can tell, logging in as an Editor isn’t an option, as I use Pro and only have one Pro account. (Buying another just to do this would be obnoxious, to say the least.) I don’t see a way to log in as the same user but with a different permissions level; correct me if I’m wrong.

I have had this same issue. I haven’t documented it well, but I have created extra options on accident many times. It would be nice to always default to the first match, but it sounds like that is expected to be the default for most people…

1 Like

This happens for me once in a while, but I haven’t taken the time to figure out what the common factors are that determine when it misbehaves. Still, it might be helpful to temporarily put single- or multiple-select fields into entry-only mode vs entry-and-editing mode.

“But another option that might have additional benefits would be to lock the options so that you can’t add a new option without going into the “customize field type” menu.”

Yes, I wish the option to disable creating new options to single select fields was available. For some reason Airtable regularly creates a new field “so” when I type the first two letters of “soon.” It’s a minor frustration that happens multiple times during my weekly review. Which makes it more than a minor pain.

so it looks like one needs an “admin” login who can edit fields, options, layouts, etc.; and then a user login to fill in tables. So we need +1 paid user…