Attachment automation to add and not replace attachment

Topic Labels: Automations
Jump to Solution
4778 11
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast


I am trying to find a way to add an attachment from a new record to a field that already has one.
The automation deletes the existing file and add the new one.
I tried adding the URL from the search step in the automation as well as of the URL of the new attachment but it does not work. Also tried to separate them with ", " Or “;” but it does not work either.

Did anyone manage to do that ?



11 Replies 11
6 - Interface Innovator
6 - Interface Innovator

Thanks for the solution @Kamille_Parks - here's how to achieve the data steps for 'Attachments' with the new (since 2021) automation structure/ naming scheme.

your first data set:

  • Record (Step 1: Trigger)|Field values|Attachments|Url ,  appears to now be
    • [when a record matches conditions]>Field Values>Attachments ⊻ Display>URL

the second set is:

  • Find Records>Make a new list of...>Field values>Attachments>flatten>Make a new list of...>URL 


5 - Automation Enthusiast
5 - Automation Enthusiast

Hello I've looked through the thread, and find yours interesting but I couldn't find the second set you mentioned. can you help me to find it?

what i'm trying to do is that I have original record in [report] table that has attachment, and when i create a record in [automation] table i want to update the original record with the newly created record's value in [report] table.
so when i run the automation it successfully updates the [report] table's original record's value but it updates(replaces) the older attachment with new attachment(if attachment is empty the null value is updated and removes the original attachment which is also problem that i did not expect) when i really want is to just add the attachment in as merge.

so i've found this thread interesting but I cannot find the 'find records' action 

I've set my trigger as when a 'record enters a view' in [automation] table's [edit view], and i'm afraid this is causing me to not find the 'find records'

Here's the property of my automation action tab


It would be very nice of you if you can tell me what's going on.



I've just found the way and am writing down the process I found for people like me.

you need to add Find Records action to locate the Original Record with Record ID prior to 'update' action.
you can add the action by
Find Record -> set Table as your original record's Table -> find records based on condition -> Where Record ID contains Original Record ID

and then you can do as above reply's second set
+ to add value -> use data from 'Find records' -> Field Values(you have to scroll down) -> original attachment field -> URL(it's under the Make a new list of)

Hope this helps people like me.