Help

Automation basics - Find a records

Topic Labels: Automations
814 5
cancel
Showing results for 
Search instead for 
Did you mean: 
Marc_Chenut
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi,

I have a trigger when a record is updated.
Then, I want to find record depending of a dynamic field from the trigger step.

When I want to add the field, I can’t “insert” it. I can only insert the first one “airtable record ID”.
All other field, there is a ‘continue’ button and nothing afterwards.

Do you know why ?

5 Replies 5

Hi @Marc_Chenut

Did you “test the trigger” in your first step?

Yes (of course). It could have been something like this though.

I can press “continue”. There is the lengh and that’s it. I can’t insert anything. The field is a formula. A basic concatenate formula.

Thank you

You’d be surprised how many times that question solved someones problem :slightly_smiling_face:

And so you’re also sure that the formula field is filled in, in your trigger data? That question also solved a lot of issues believe it or not :slightly_smiling_face:

Normally it should work. Some users on this forum said it helped to remove and rebuild that step. @kuovonne helped some of them, so maybe she knows more?

Marc_Chenut
5 - Automation Enthusiast
5 - Automation Enthusiast

thank you for your reply.

I did it all before. Same. Here are the screenshots:
Capture d’écran 2021-08-11 à 21.49.17

I am looking to the formula field “Code tarif” with data “8 Excursion à Sian kaan en bateau”.

Then this is the only field I can insert for the action and condition

Capture d’écran 2021-08-11 à 21.49.35

When I scroll down to the field I am looking for the right field, I can “continue”

Capture d’écran 2021-08-11 à 21.49.43

Then nothing after : Capture d’écran 2021-08-11 à 21.49.50

Do you know why its doing this ?

If you duplicate your formula field and turn it to text, you can add text value in dynamic filter.
But you ca’t use formula field in filter (unless it’s primary, i guess, but not sure)
“At the moment, it is only possible to use a date or single-line text field when using the dynamic conditions option”.

that’s quite strange, i’m using simple automations to maintain links between tables in large bases, and often encounter such ‘limits of input data type’

you can use workarounds:

  • create additional text field, add ‘update record’ step 2, “construct” your value, using the same concatenation, in ‘step 3 - find records’ - use value from text field

OR

  • create step 2 ‘run script’, define any variable name (‘var’ for example), insert value from formula field (and it allows you to do it … i don’t understand what’s the problem for airtables to let do the same in Dynamic filter for ‘Find records’)
    script will consist from one line
    output.set(‘anyLabel’,input.config().var)

then you can use this ‘anyLabel’ as input data for next step

I don’t know which is better, second lets you to avoid redundant field, but usually I’m trying to act without scripting, where it’s possible.

Well, i hope they’ll fix it soon.