Help

Upcoming database upgrades. to improve our reliability at 03:30 UTC on Feb. 25 / 7:30pm PT on Feb. 24. Some users may briefly experience slow load times or error messages. Learn more here

Automation Emails with Record Grid that links to the referenced Records

Topic Labels: Automations
Solved
Jump to Solution
477 3
cancel
Showing results for 
Search instead for 
Did you mean: 

Hi there,

We use email automation to send emails include a grid with records in the email body. How do I include a link to those records in the grid so that email recipients with Airtable accounts can click the referenced record and immediately be taken to the correct record to update?

thanks!

1 Solution

Accepted Solutions

@ScottWorld Thanks for the welcome and the quick help. The new formula worked perfectly, except that RECORD_ID() returns “recXXXXXXX”. So the final formula is:

https://airtable.com/appXXXXXX/tblXXXXXX/viwXXXXXX/”& RECORD_ID()

Once I reran a test of the Find records step of the Automation, the links worked perfectly. Thanks again!

See Solution in Thread

3 Replies 3

Welcome to the community, @Josh_Bushinsky!

You will need to create another field on your grid, which is a formula field that equals the URL for that record.

If you expand one of your records, you will see that its URL looks something like this:

https://airtable.com/appXXXXXXXXXX/tblXXXXXXXXXX/viwXXXXXXXXXX/recXXXXXXXXXX

The URL shows the app ID, the table ID, the view ID, and the record ID.

So create a formula that matches everything but the record ID, and then for the record ID, use the function RECORD_ID()

So your final formula would look something like this:

"https://airtable.com/appXXXXXXXXXX/tblXXXXXXXXXX/viwXXXXXXXXXX/rec" & RECORD_ID()

@ScottWorld Thanks for the welcome and the quick help. The new formula worked perfectly, except that RECORD_ID() returns “recXXXXXXX”. So the final formula is:

https://airtable.com/appXXXXXX/tblXXXXXX/viwXXXXXX/”& RECORD_ID()

Once I reran a test of the Find records step of the Automation, the links worked perfectly. Thanks again!

Oh, haha!! Thanks for the correction!! :stuck_out_tongue: And glad that it worked!