Help

Welcome to the Airtable Community! If you're new here, check out our Getting Started area to get the most out of your community experience.

cannot assign list of object to collection of complex types

Solved
Jump to Solution
466 16
cancel
Showing results for 
Search instead for 
Did you mean: 

What does this mean?

"cannot assign list of object to collection of complex types"

I can't select any field values. And how do I make it so I can select it. 

Skidz_0-1671085790057.png

 

1 Solution

Accepted Solutions

Tested and it now works, quick fix...

See Solution in Thread

16 Replies 16

What are you trying to do with the found records? Are you trying to create or update a record? If so, what field type are you trying to set?

I'm trying to create a new record with the "find record" from the previous step.

i have the same problem now. It used to work properly and now i can't add any info.

Same here. I can't even recreate the working automation now since I can't select the field values anymore. And this is getting from the same table and data. It doesn't make any sense. 

Same here! Help!

See screenshot

I'm also having this issue- I tried replicating existing parts of automations that I set up before today and it won't let me. But it was definitely working fine last week. I'm contacting Airtable support to see if they can sort out what's going on


I am also having this issue. Just trying to send a list of records to my email address, such as 'daily tasks'. I've  attached photos so you can see the difference.

 

what it used to be.png

This is how it used to operate.

what it is.png

This is how it currently operates.

 

 

I am having the same issue. Old automations are working but cannot add a new automation with Grid or List options. Please fix this ASAP! 😞

Hi everyone, i contacted Airtable support and this is their response : 
«Thank you for sharing that! I'll have this escalated to our technical team since this affects multiple users. I'm unable to see anything internally I'm afraid. I know it's not ideal and I apologize for that. I'm going to mark this as high priority in order to get this solved in no time.»
So let's hope it doesn't take too much time ! 

I'm running into this problem as well. All I'm trying to do is pull a list of emails from a 'Find records' action and it won't do it, even though I'm copying from another automation that is currently working and exactly the same

I'm having the same problem. Worked fine a few days ago and now I can't replicate the automation. 

As others have reported - the old automations are working fine with this functionality but I can't set up any new ones that have this functionality - I just get the 'cannot assign list of object to collection of complex types' message when I try.

Started happening Yesterday

Same issue here! Hoping for a fix soon.

Airtable support just got back to me saying they've been able to fix the issue and I can confirm it's working again for me. From their email:

Thank you for hanging with us while our engineering team worked on a fix for the Find Records action step being unavailable to bring in values to the following step. The fix for this is officially released. You may need to refresh your browser or clear your cache for the fix to take effect.

Please don't hesitate to reach back out to Support if you continue to have any issues with this.

Tested and it now works, quick fix...