Copy data from one column to a link to another record column

Topic Labels: Automations
823 4
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hey there,

I have gone through quite some posts about this topic in the community already, but none seems to solve my problem or maybe I just haven't fully understood how to solve it yet.

I have a table "Product stock" and another table "Product catalogue". The product catalogue contains information how many products are in stock by checking via a link and lookup field to the stock table. The link between these table is the product code.

However whenever the stock is updated (e.g we have a new product in stock) I have to manually copy the product code from a text column to the link-records field. I would like to automise this step. My approach here is the following:

- Trigger: when a record is updated (product-stock)

- Actions:

  • Find records: in product catalogue, where product code isn't empty
  • Update records: in product catalogue: 
    • Record ID: from find records - selected the link field product-number
    • fields: link field product-number, select fields to show product number (text field)

When I test the automation I get the error: "received invalid inputs"

I hope I explained my problem in an understandable way. I attached some screenshots to provide clarification, but let me know if I can provide further explanation.

Thank you for your help in advance. 

Kind regards







4 Replies 4

I think it would be easier to update the 1 trigger record with the list of found Record ID's in your "find records" step, rather than to the same to many records in your Catalogue table. 

For your linked field "ABS Code Lagersuche", then use "Make a new list of ... Airtable record ID".



5 - Automation Enthusiast
5 - Automation Enthusiast

Thank you for your reply.

Unfortunately I still receive the error "invalid inputs" - I have also tried this for various other combinations of fields and none of them is working.

Is there a list of criteria the input needs to fullfill in order to be valid?

Kind regards


Have you tried retesting all the previous steps before you try the update action? Have you tried turning the automation on and letting it run with a "real" record?

5 - Automation Enthusiast
5 - Automation Enthusiast

Yes, I have tried that now. It returned the same error as before - also for a real record.