Help

Date format changed when table view is added to Send email automation

Topic Labels: Dates & Timezones
Solved
Jump to Solution
237 5
cancel
Showing results for 
Search instead for 
Did you mean: 
AndyLecap
4 - Data Explorer
4 - Data Explorer

I use the found records automation to create my report and the date is in the correct format, her DoB is 10th July

AndyLecap_1-1719838357362.png

But when I add this as a grid of records to the Send an Email automation, the DoB shows as 7/10/1953 i.e. 7th October.

AndyLecap_2-1719838531056.png

and this is what arrives in the recipient's email. 

 

 

1 Solution

Accepted Solutions
Pascal_Gallais-
6 - Interface Innovator
6 - Interface Innovator

Hello Andy,

In case changing field settings does not work.

I have faced the same problem with automations when printing a date in a document or a mail. I solved this issue by adding a formula field in my table to format the date as I want it to be printed, for example 

DATETIME_FORMAT({Date},'DD/MM/YYYY')), and then use this field in my automation when printing to a document or a mail.
 
Regards
 
Pascal

See Solution in Thread

5 Replies 5

Might be a timezone issue.  Could you try setting your "DOB" field to "GMT/UTC" and see what the value is?

Pascal_Gallais-
6 - Interface Innovator
6 - Interface Innovator

Hello Andy,

In case changing field settings does not work.

I have faced the same problem with automations when printing a date in a document or a mail. I solved this issue by adding a formula field in my table to format the date as I want it to be printed, for example 

DATETIME_FORMAT({Date},'DD/MM/YYYY')), and then use this field in my automation when printing to a document or a mail.
 
Regards
 
Pascal

Can't see GMT/UTC option for our date fields. I tried the European one and that had no effect.

Thank you Pascal.

Ah, I completely misunderstood your problem, sorry about that!  Glad you got it sorted!