Help

Find record in automation using current record

Topic Labels: Automations
Solved
Jump to Solution
552 14
cancel
Showing results for 
Search instead for 
Did you mean: 
CharlieMullin
6 - Interface Innovator
6 - Interface Innovator

I have a pre-filled form that is launched from a button in a record in the Assets table. When the form is submitted, the automation is triggered. A new record is created in the Updates table. Then, there's a Find Record step where a condition is entered to find the record to be updated in the Assets table. Right now, I'm using the condition Today's Date.

That's fine for testing but what I really want to do is let the Find Record value be the record from the Assets table from which I launched the form in the first place using a button.

How do I refer to that Rec ID?

 

1 Solution

Accepted Solutions

Roger that.  I've put together a working version of what I think you're trying to do here:

Screenshot 2024-04-19 at 1.02.51 PM.png

Screenshot 2024-04-19 at 1.02.47 PM.png

Screenshot 2024-04-19 at 1.02.45 PM.png

Form link prefills the record ID of the Asset record, on form submit it creates a record in "Updates" which triggers an automation that updates the "Asset" record with a link to the new "Update" record

See Solution in Thread

14 Replies 14

Hm, if I were you I'd try:
1. Create a field in the "Updates" table called "Asset record ID"
2. In your prefill URL formula field in "Assets", prefill the new field from step 1 with the Asset record's "record_id()" value

This way the submitted "Updates" record will include the record ID of the record from the Assets table which you clicked the button on, and you can use that record ID for your search

I'm not entirely clear on the use case, but you could also just link them together directly too?

jsep
6 - Interface Innovator
6 - Interface Innovator

Adam's solution should work, and you can also hide the "Asset Record ID" field in the form since it is for your use only.

To pre-fill form fields, follow this guide: Prefilling a Form via Encoded URL

To hide the "Asset Record ID", use the visibility rule with two conditions, as shown in this screenshot.

jsep_0-1713227531807.png

If you need help implementing this solution, fell free to schedule a free call with me.

 

 

CharlieMullin
6 - Interface Innovator
6 - Interface Innovator

Hi Adam, I pretty much had the tables set up with the Rec ID available and I've now added that Rec ID field to the pre-filled form. But I'm still stymied about how to point to the Rec ID value in the Automation,

CharlieMullin_0-1713288595871.png

Shouldn't I be able to set a condition that refers to that Rec ID value? in the Conditions section above I can only add a string as opposed to a value in a field.

I'm sure I'm missing something fundamental. I do need the Find Record step, right?

 

jsep
6 - Interface Innovator
6 - Interface Innovator

@CharlieMullin  you have to dynamically filter the record using the form's "Asset Record ID".

Like this:

chrome-capture-2024-3-16.gif

I hope this helps! If you need help implementing this solution, feel free to schedule a free call with me.

Totally forgot about selecting Dynamic to present the fields. Thanks for that.

Now I'm getting this error:

Not sure what that means. Asset Rec ID is a short text field, so should be OK. Here are the two relevant fields:
CharlieMullin_3-1713306471889.png

Asset Record ID was submitted via the pre-filled form. Original Asset Rec ID has a formula to fetch its value from a Rollup field that contains the Rec ID from the Assets table. You can see that those values match (the last three records.)

Thoughts?

 

Sorry I don't see the error in your reply.

Feel free to schedule a free call with me, and we'll make it work.

 

re: Shouldn't I be able to set a condition that refers to that Rec ID value? in the Conditions section above I can only add a string as opposed to a value in a field.

I'm sure I'm missing something fundamental. I do need the Find Record step, right

Yeap, you need to set a condition to refer to that value and you do need the Find Record step.  In your "Assets", create a formula field called "Record ID" with the formula `record_id()` and use that in your Find Record step.  Specifically, the Find Record step will look for records in "Assets" with a "Record ID" value that matches the value of "Asset Rec ID"

--
As an aside, I'm kind of curious what the formula is for the field "Original Asset Rec ID".  Not related to the stuff I mentioned above mind you, I'm just wondering how you set that bit up

Hey Jsep, here's that missing screensot with the error:

CharlieMullin_0-1713366694174.png

See the Filters error msg at the bottom.

Here's the Original Asset Rec ID properties:

CharlieMullin_1-1713368095103.png