Help

Linked Records Question

Topic Labels: Automations
111 7
cancel
Showing results for 
Search instead for 
Did you mean: 

Can I create an automation that -

~Searches for a record in Table 2 that matches a field in Table 1
~Then automatically links the two records in Table 2’s linked record field ?

Specifically, I have a Fundraising table (Table 1, above) where, when I add a new donor, I want it to auto-link my linked record field to that person’s entry in my Contacts table, rather than me having to match each one individually.

Not figuring out how to do this with Find Record or Update Record automation functionality - is it possible?

7 Replies 7

Yes, this is possible. And it is done in the exact way that you described in your post. Which part of your automation is failing? Please post a video or screenshots.

I’m pretty I have the “find record” step set up correctly -

Screen Shot 2022-09-07 at 8.23.25 PM
Screen Shot 2022-09-07 at 8.23.37 PM

But with the “update record,” I don’t understand what to enter for Record ID, none of these terms make any sense to me—

Screen Shot 2022-09-07 at 8.24.15 PM
Screen Shot 2022-09-07 at 8.24.20 PM

I just want it to auto-pair with the record that it found in the “find record” step.

I think what keeps throwing me also is “insert value from field,” – I don’t want to insert a value from a field, I want to insert a value into a field (that comes from another table), right?

You would use the “Airtable Record ID”.

However, your trigger is set for “when a record is created”. That only works if you added the record through a form or through the API. Otherwise, you will need to use a different trigger, such as when a record matches conditions, and choose a checkbox or a value from a single select field.

Hi,
Yes, it can be confusing at the beginning. Find Records returns array of records, so retrieving single ID from this array needs workaround. Good news is that you don’t need to do it.
You should update the record in Table 1, take it’s ID from trigger.
Then you should define field. Choose field in Table 1 that links to table 2 and insert there whole result of your ‘Find record’, ‘a new list of…’ record ID.

In your case the result is 1 record. It’s still an array (or list) that consists of 1 element. If your ‘Find record’ action will find 5 record, it will link to all of them. If none - puts empty array, that means empty link field.
that’s a usual place to confuse - trying to put array into something awaiting single value.

In addition to warning with ‘Create record’ (when you create the record manually, automation will run before you fill Funder Name), you should be careful with ‘contains’ clause. For example, searching for ‘contains “active”’ will get you all “inactive” as well, ‘contains 1234-2 will return 1234-20…1234-29’.
I’m not sure how automation work with ‘contains [empty value]’, or ‘contains [space]’, but you can receive a maximum of 100 results and link to each of them.
It doesn’t mean you should not use it, just be warned and if something fails, check values in ‘run history’ to investigate.

The tests are doing exactly what I want them to do, so I believe it’s set up correctly, thanks!

It doesn’t appear to be automatically running the automation on all of the existing records that match the condition, only the ones I choose to test. How can I get it to do that? Automation is on.