Re: ( - integromat) i want to append a array of record id's to a multiple field record

4580 5
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer


i have created 2 tables, one for houses (woningen) and the other one users.
Scherm­afbeelding 2022-11-07 om 15.10.13

So the users have a profile with for example min and max what they want to pay for a house.
Scherm­afbeelding 2022-11-07 om 15.04.22

So the house goes to a filter of all the users profile
Scherm­afbeelding 2022-11-07 om 15.04.12

to not overwrite the user that is added to the field i am using a array aggrergator. because i want to send the users in a list to have multiple users instead of one that is overwritten
Scherm­afbeelding 2022-11-07 om 15.04.03

but it gives me this error:


Validation failed for 3 parameter(s).

  • Collection can’t be converted to text for parameter

Scherm­afbeelding 2022-11-07 om 15.03.54

7 Replies 7
6 - Interface Innovator
6 - Interface Innovator

Have you tried listing all the linked records separated by commas? It’s been awhile, but I recall not needing to turn it into an array for adding multiple linked records.

Scherm­afbeelding 2022-11-07 om 15.49.37
@Carl how seperate ‘10.ID’ it by commas

Okay, so I am wrong. Just using a list might be in Airtable’s own automations. I swear I’ve done it like that before. But regardless, you don’t need the array aggregators, just use add array function.

add ( array ; value 1 ; value 2 ; … ) (

What I’m doing here is adding the new ID into the existing array in an update Airtable record action.

Here’s a screenshot:
Screen Shot 2022-11-07 at 10.25.03 AM

nothing is added to the field in airtable:

Scherm­afbeelding 2022-11-07 om 17.23.26
Scherm­afbeelding 2022-11-07 om 17.23.15

@Carl without add, stays 1 users because its overwrite the old one
Scherm­afbeelding 2022-11-07 om 17.24.39
Scherm­afbeelding 2022-11-07 om 17.24.22

Hey @Jabir_Tisoudali ,

Linked records field expects array of record ids. Something like

[ "rec111","rec222","rec333"]

The aggregator returns array of objects (with each object being {“IMTKEY”:“recXXX”}), so that does not match the destination.

You should transform the array of objects to simple array using map function. If I am not mistaken something like this:

map(yourArray[] ; __IMTKEY__)

I’d double check that you’re mapping a new ID when you do the add(array;value) formula and not one that is already in the original array. I just did the same set up and it worked as expected.