Help

Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

Outlook automation not working consistently

Topic Labels: Automations
Solved
Jump to Solution
324 5
cancel
Showing results for 
Search instead for 
Did you mean: 

I have set up a simple automation where the trigger is an email being put into a particular folder on my Outlook email system. This then triggers the creation of a task, taking some of the information from the email.
It runs perfectly when you test it, so I then made it live and put 5 emails into this folder. Only 2 have come across as tasks - I simply can not work out why the others haven’t (I left it overnight, so assuming it isn’t a timing issue).

Any help / pointers on this would be much appreciated.

1 Solution

Accepted Solutions

Not sure why the Outlook automations aren’t working for you guys, so you may want to open a support ticket with support@airtable.com to see if they can help.

I just tested Airtable’s Outlook automation on my end 8 different times, and it worked perfectly fine for me each time. I even tried all the different types of messages, too:

  1. Unread message in inbox
  2. Unread message in a specified folder
  3. Read message in a specified folder

It worked perfectly fine each time.

I also tested the same 8 messages with Make, and it always worked perfectly fine there too. So a possible solution and/or troubleshooting step would be to try it in Make to see what happens:

If it doesn’t work in either Airtable or Make, then it’s likely a problem with your Outlook permissions or something on the Outlook end. But if it only works in one platform but not the other, then the problem is something on the automation side.

p.s. I prefer doing most of my Airtable automations in Make anyways, because it’s so much more powerful and customizable.

See Solution in Thread

5 Replies 5

I’m trying to do the same thing and am running into the same issue.

I didn’t get an answer to this here, but the problem was removed as the client I was doing this work for has moved their email to GSuite (for a number of reasons) and this works perfectly now. I am sure that there will be a sensible reason why the MS Outlook wasn’t working but I have yet to come up with a solution to this one.

Not sure why the Outlook automations aren’t working for you guys, so you may want to open a support ticket with support@airtable.com to see if they can help.

I just tested Airtable’s Outlook automation on my end 8 different times, and it worked perfectly fine for me each time. I even tried all the different types of messages, too:

  1. Unread message in inbox
  2. Unread message in a specified folder
  3. Read message in a specified folder

It worked perfectly fine each time.

I also tested the same 8 messages with Make, and it always worked perfectly fine there too. So a possible solution and/or troubleshooting step would be to try it in Make to see what happens:

If it doesn’t work in either Airtable or Make, then it’s likely a problem with your Outlook permissions or something on the Outlook end. But if it only works in one platform but not the other, then the problem is something on the automation side.

p.s. I prefer doing most of my Airtable automations in Make anyways, because it’s so much more powerful and customizable.

Thank you for this - much appreciated.

Thank you both for the responses : )