Airtable Cobuilder is here! Learn more about our new no-code app creation feature, powered by AI on the Airtable Academy

Re: Failed to execute 'fetch' on 'Window': Illegal invocation

Jump to Solution
2304 0
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi there,

I’m attempting to integrate my airtable database api into a React project. I installed airtable using ‘npm install airtable’. I also followed all the directions on to configure my api/base and create a function to list the records. However, when my app attempts to run that function, I get the error “Failed to execute ‘fetch’ on ‘Window’: Illegal invocation.” When I click on the error in dev tools, its source appears to be in the airtable base file–which I don’t have access to as it’s part of the npm package.

I did see this topic mentioned in another post, and tried what was recommended there, however, it did not solve my issue.

Has anyone else run into this issue and found a work around?

1 Solution

Accepted Solutions

@Frenchy_French - if you’re still stuck, I’ve added a workaround to the issue above

See Solution in Thread

5 Replies 5
4 - Data Explorer
4 - Data Explorer

I have the same issue

Someone else does on github as well:

Would be great if someone from Airtable could weigh in on this

@Frenchy_French - if you’re still stuck, I’ve added a workaround to the issue above

Thanks for your help, but your workaround requires changing line 8 on the fetch.js file.
But the problem is in latest version of the airtable.browser.js file, which is the only file i’m using.
The only workaround that I found (for my case), is not using the latest airtable.browser.js file
And I’m using the one that is located here /test/test_files/airtable.browser.js

4 - Data Explorer
4 - Data Explorer

@Alex_Rubner Thanks for the work around! It worked for me. I originally tried changing the airtable.browser.js file, but the error kept happening.

The change suggested by @Alex_Rubner is on line 313 in airtable.browser.js :
Change it as suggested and it should work.