Help

Welcome to the Airtable Community! If you're new here, check out our Getting Started area to get the most out of your community experience.

Uploading Attachments with Integromat

Topic Labels: API
Solved
Jump to Solution
4292 10
cancel
Showing results for 
Search instead for 
Did you mean: 

I’m hoping to use JotForm to add some functionality for recruitment applications, and having some trouble with Airtable’s attachment field when mapping the fields using Integromat.

Jotform is sending the attachment data as a URL, which I’m mapping to the attachment field in Integromat, as below:

image

This successfully adds to Airtable:

image

And creates a record with the attachment.

However, it seems that the Airtable is then immediately deleting the attachment!

image

I doesn’t do this when I manually enter the same attachment URL, only when it’s mapped from JotForm.

Any ideas or prior experience would be appreciated!

1 Solution

Accepted Solutions

I have actually solved this one! There was a setting in JotForm that required login to download files. Turning that off enabled it to upload correctly.

This is less secure, but a huge time-saver.

For those experiencing this on other platforms, I would imagine it’s similarly a permissions issue with where you are hosting your files.

See Solution in Thread

10 Replies 10

@Josh_Haywood,

Going out on a limb here, but is it possible the image URLs to Jotform are secure and Airtable is unable to render them, therefore, it removes them?

This would explain why it works manually if you copied and pasted a Jotform URL into Airtable and in an adjacent browser tab you had a security context in place to Jotform. Airtable would see the route to the image URL as unimpeded and think - that’s cool, whereas, in an automated, lights-out process with Integro, it would have no such route to the Jot server.

Having same issue, has anyone figured out a solution?

Hi @Skyler_Proctor

Did you try going to Integromat help forum, on Facebook? Maybe someone from the group can help. You could also try Integromat Support.

Just a few other suggestions.

Mary K

One possible workaround would be to insert a step that saves the file to something like Google Drive or Dropbox, and then you go from there into Airtable.

Actually I said I had the same problem, but in fact this problem is occurring from Google Drive to Airtable

I have actually solved this one! There was a setting in JotForm that required login to download files. Turning that off enabled it to upload correctly.

This is less secure, but a huge time-saver.

For those experiencing this on other platforms, I would imagine it’s similarly a permissions issue with where you are hosting your files.

Yep - that’s what I said. :winking_face: Glad it’s working.

I have the exact same problem with files (images & PDFs) uploaded to S3. Does anyone know what permissions I must turn on to let Airtable download the file and render it in the base?

I feel like I’ve turned pretty much everything public but still, Airtable uploads the file and deletes it immediately.

Thanks!

Got it!

Here’s the full answer for those who has the same settings problem: https://stackoverflow.com/questions/58282974/s3-make-uploaded-files-public-by-default

2022 workaround that might help some people: