Help

DATEADD

Topic Labels: Formulas
Solved
Jump to Solution
571 4
cancel
Showing results for 
Search instead for 
Did you mean: 
MSalas
4 - Data Explorer
4 - Data Explorer

I'm having trouble with using the DATEADD function (and yes totally new at this). I'm trying to add 3 months to a date in another column. I've technically gotten the formula to work but it's not quite getting the desired date. So for example if my date is 4/1/2024 and the formula is adding 3 months it's calculating 6/30/2024. I need it to actually calculate 7/1/2024. I've tried to add a day to the formula but keep getting an error. Any help would be great. Thanks in advance.

1 Solution

Accepted Solutions

Could you provide a screenshot of your date and formula field with the timezones displayed?

This is my formula:

DATEADD(
  Date,
  3,
  'months'
)

And this is my result:

Screenshot 2024-02-08 at 12.12.02 PM.png
And so kuovonne's probably right about it being a timezone issue since our formulas are the same but our outputs are different

See Solution in Thread

4 Replies 4

When a date related field is off by one day, it is often a timezone issue.

Check the timezone settings in the formatting options for your formula result.

Time zones are the same. I think what I need is to add 1 day. I think the formula is correct: DATEADD ({Annual Due}, 3, 'months'). So it's adding 3 months, but instead of going to the exact date three months later it's going to the day before, e.g., 4/1/2024 and then the formula column is 6/30/2024. I've tried to do this same formula this way to add the extra day but it doesn't quite work: DATEADD ({Annual Due}, 3, 'months', 1, 'day'). I know I'm missing something here to add the extra day. 

Could you provide a screenshot of your date and formula field with the timezones displayed?

This is my formula:

DATEADD(
  Date,
  3,
  'months'
)

And this is my result:

Screenshot 2024-02-08 at 12.12.02 PM.png
And so kuovonne's probably right about it being a timezone issue since our formulas are the same but our outputs are different

You were right. Now just getting it the right time zone haha. Thank you very much. I thought I had done this but apparently not.