Help

Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

How to add a line break to Formula?

Topic Labels: Formulas
Solved
Jump to Solution
2121 5
cancel
Showing results for 
Search instead for 
Did you mean: 

How to make a line break when I do strings concatenation?

For example, I have 4 fields and I do a concatenation:
"field_1: " & value_1 & ", field_2: " & value_2 & field_with_lots_of_text

I’m trying to do smth like that:
Screenshot 2020-04-26 13.34.35

If I do like thins, it works ok:
Screenshot 2020-04-26 13.31.23 Screenshot 2020-04-26 13.31.40

But I want to add more data and add a line break:
Screenshot 2020-04-26 13.33.30 Screenshot 2020-04-26 13.34.24

1 Solution

Accepted Solutions

In your grid view, it actually did work, but it’s truncating all of your data onto the same line for you so you can see more of your data. If you expand the cell by clicking on that little blue icon that appears (or by hitting SHIFT-SPACE on your keyboard), the cell will open up and you will see that your line breaks are actually there.

Alternatively, if you increase your row heights by clicking on the “row height” button in your toolbar, you will be able to AUTOMATICALLY see your line breaks without expanding the cell. (Well, you’ll be able to see as much data as will fill the height of the cell.)

I’m actually not sure how to make all the lines of a formula field AUTOMATICALLY visible in gallery view. In gallery view, it seems like your only option is to MANUALLY double-click on each gallery card to see all your line breaks intact. (But perhaps somebody else knows how to view all the lines of the formula without double-clicking on the gallery card.)

It seems like Airtable doesn’t like to automatically increase the height of formula fields which have multiple lines on them. Unless someone else knows how to do this, this seems like a possible oversight in Airtable to me.

See Solution in Thread

5 Replies 5

You can get rid of the <br> and replace it with

& "\n" &

Works, but not the way expected:
Screenshot 2020-04-26 13.49.30 Screenshot 2020-04-26 13.49.40 Screenshot 2020-04-26 13.49.45

Is it possible to make it work at the Gallery view?

In your grid view, it actually did work, but it’s truncating all of your data onto the same line for you so you can see more of your data. If you expand the cell by clicking on that little blue icon that appears (or by hitting SHIFT-SPACE on your keyboard), the cell will open up and you will see that your line breaks are actually there.

Alternatively, if you increase your row heights by clicking on the “row height” button in your toolbar, you will be able to AUTOMATICALLY see your line breaks without expanding the cell. (Well, you’ll be able to see as much data as will fill the height of the cell.)

I’m actually not sure how to make all the lines of a formula field AUTOMATICALLY visible in gallery view. In gallery view, it seems like your only option is to MANUALLY double-click on each gallery card to see all your line breaks intact. (But perhaps somebody else knows how to view all the lines of the formula without double-clicking on the gallery card.)

It seems like Airtable doesn’t like to automatically increase the height of formula fields which have multiple lines on them. Unless someone else knows how to do this, this seems like a possible oversight in Airtable to me.

Thank you very much!
I decided to split it into to cells.