Help

Re: If with checkbox not working

Solved
Jump to Solution
1853 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Valentin_GUENIC
6 - Interface Innovator
6 - Interface Innovator

Hi everyone !
Here’s a very simple formula :
IF(
{Edition}=1,
{Genuine Console Family},
IF(
NOT(
AND(
{Accessories list},
{Games}
)
),
{Genuine Console Family}
)
)

I don’t know why, the first IF doesn’t work at all. I check the checkbox and nothing happens.
But, when Accessories list and Games have values, I can check and the field is fill with the right value (Genuine Console Family).

Thanks a lot for any help.

14 Replies 14

Are you sure {Genuine Console Family} is not empty?

Absolutely !
Because it fills up while Accessories list OR Games is filled.

So when Accessories List and Games are both empty then Genuine Console Family is also empty?

Here’s a link to an Example base that works with the behaviour you have described.

Genuine Console Family should be empty when: Accessories List and Games are both empty and checkbox unchecked
Genuine Console Family should be filled when: Accessories list OR Games are not empty, OR checkbox checked.
:slightly_smiling_face:
Yes I know it’s a bit weird. I have some conditional statements in order to filter my linked fields (accessories and games) depending on this field. It checks if there’s a value and this value is connected to a family of console, so are accessories and games.

Valentin_GUENIC
6 - Interface Innovator
6 - Interface Innovator

I made a mistake… and I’m sorry.
I forget to mention that I need to fill another field (hardwares) in order to have Genuine Family Console field not empty… so it works like a charm !
Thanks for helping my brain working :winking_face: