Help

Getting Interface > Record Summary > Timeline element correct records to populate

Topic Labels: Interface Designer
Solved
Jump to Solution
689 2
cancel
Showing results for 
Search instead for 
Did you mean: 
BryceD
5 - Automation Enthusiast
5 - Automation Enthusiast

I have a base with multiple tabs that have links between them. Tab 1 is Digitization Projects. Tab 2 is Scheduling.

Tab 2 Scheduling is made up of individual task records. Each of these links back to a project record on Tab 1. The individual task records on Tab 2 all have start and end dates.

From within the Record Summary Interface, I want to be able to select a single Digitization Project (from Tab 1), and have a timeline element display only the records and dates (from Tab 2) that are linked to that project.

I have not been able to figure out how to filter things to allow this. Right now, it shows me ALL the records from Tab 2, whether or not they're associated with the Digitization Project (from Tab 1) that I've selected in the Record Summary Interface.

Screenshots attempting to illustrate below. Any suggestions would be most welcome. Thank you!

Digitization Projects (Tab 1)

Tab 1.png

Scheduling (Tab 2)

Screen Shot 2023-02-21 at 4.18.17 PM.png

Record Summary with Timeline element visible but not working as I'd like it to. 

Screen Shot 2023-02-21 at 4.22.50 PM.png

1 Solution

Accepted Solutions
TheTimeSavingCo
18 - Pluto
18 - Pluto

Hm, instead of using a filter, can you use a Record Picker element instead?  That would give you the exact functionality you want I think?

Screenshot 2023-02-22 at 10.50.07 AM.png

Screen Recording 2023-02-22 at 10.50.22 AM.gif

Link to base

See Solution in Thread

2 Replies 2
TheTimeSavingCo
18 - Pluto
18 - Pluto

Hm, instead of using a filter, can you use a Record Picker element instead?  That would give you the exact functionality you want I think?

Screenshot 2023-02-22 at 10.50.07 AM.png

Screen Recording 2023-02-22 at 10.50.22 AM.gif

Link to base

BryceD
5 - Automation Enthusiast
5 - Automation Enthusiast

Ah-ha! Thank you so much! I managed to get it working now. Because I started from the record summary template rather than building the interface from scratch, some of my presets were off. When I built it from scratch, I got it looking just how I wanted. Thanks for the quick guidance, much appreciated.