Help

Interface viewers are seeing "cannot access this data"

Topic Labels: Interface Designer
943 3
cancel
Showing results for 
Search instead for 
Did you mean: 
jills
5 - Automation Enthusiast
5 - Automation Enthusiast

I created an interface with two pages, and one is not showing the information to the viewers. They are getting an error that says "Cannot access this data."

Other details...

  1. There are two pages in the interface --- one is a list, and one is a record detail page that only allows them to see their own record.
  2. They are all able to see their own record, but the list won't show up. 
  3. The "Users can see" is set to "Specific records" and has one condition on it (status field = active).
  4. When I preview the page as the viewers, I'm able to see everything.

What am I missing?

3 Replies 3
jills
5 - Automation Enthusiast
5 - Automation Enthusiast

This kind of resolved on its own. I ended up adding another page (a dashboard page with a grid) and then deleting that, and then the original list view started showing up for people. So, I don't know what the issue was, but it's working now.

Hi Jill! Thank you for flagging this behavior for us. I've done a bit of digging into this behavior and it sounds like a match for a bug that our team is presently working to resolve. Presently reproducible with interface-only users in the list layout, if a previously visible field is deleted, this error can appear. We're hoping to have a permanent fix for this out in the upcoming week, though in the interim, re-adding a layout routinely resolves this, as you've found. Let me know if this gives you any further trouble and I'm happy to take a closer look with you.

Russell_Bishop1
7 - App Architect
7 - App Architect

We've just received this message today too – one of our interface-only read-only users can't view a list.