Help

"Edit records inline" - make certain fields uneditable

Topic Labels: Interface Designer
Solved
Jump to Solution
164 2
cancel
Showing results for 
Search instead for 
Did you mean: 
airtable_fan
4 - Data Explorer
4 - Data Explorer

Hi all,

I'm building a List Interface

In that list, I have enabled the "Edit records inline" setting. Now, all fields, even the ones that have been locked in the underlying Base, are editable from the interface. How do I keep the locked fields locked in the interface?

1 Solution

Accepted Solutions
TheTimeSavingCo
18 - Pluto
18 - Pluto

Hmm, setting the field permission to "Nobody" works fine for me and prevents the field from being edited in the interface

In the following screenshot, the "Type" field has a field permission set to "Nobody" and is uneditable in a List interface with "Edit records inline" turned on.  The "SKU" field is editable as it does not have field permissions set

Screenshot 2024-07-05 at 11.09.42 AM.png
If you could provide a read-only invite link to a duplicated copy of your base I could try to help troubleshoot this for you!

See Solution in Thread

2 Replies 2
TheTimeSavingCo
18 - Pluto
18 - Pluto

Hmm, setting the field permission to "Nobody" works fine for me and prevents the field from being edited in the interface

In the following screenshot, the "Type" field has a field permission set to "Nobody" and is uneditable in a List interface with "Edit records inline" turned on.  The "SKU" field is editable as it does not have field permissions set

Screenshot 2024-07-05 at 11.09.42 AM.png
If you could provide a read-only invite link to a duplicated copy of your base I could try to help troubleshoot this for you!

@TheTimeSavingCo thank you! Setting the edit right to "Nobody" did the trick for me

What seems to have been happening is that the Preview feature in Interfaces doesn't alway render permissions correctly - initially the field access edit was enabled for certain users only, but all users appeared to have edit rights in Preview

Thanks for helping to resolve!