Airtable forces change of Lookup field type for sync

Topic Labels: Data Sync
951 4
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

AirTable seems to have made a change to the sync implementation in a way that has crippled a critical support process/automation we have in place. Based on the fact that this support article was updated today and one of our sync fields that used to be a Lookup (and on which downstream logic relied upon) is now a text field, we can only assume that a breaking change was deployed with no advance notice.

Anyone else experienced this or have any issues as a result of this?

4 Replies 4
5 - Automation Enthusiast
5 - Automation Enthusiast

I'm experiencing the same thing.

To clarify, it is happening to a field that is a linked type in source, and originally synced to synced table as single line text.

We then contained the type to linked field, and since the name was correct, it has been working perfectly for 10 months.

Now, it got converted back in the past couple hours to a text only field and I can't change it back.

Then I try, it links it momentarily, and then immediately goes back to a single text type without any warning.

Airtable Employee
Airtable Employee

Hi @Drew_Schumacher @stephenheindel, can you share more details about the issue?

- Prior to this issue, were past syncs all successful with no warning or errors?

- Is the linked record column (on the sync target base) linking to a valid table in the base? After it is linked, is there a corresponding linked column in that table?

- If you want to, it may be helpful to provide us the base id. Additionally, you may choose to share the base with Airtable support.


5 - Automation Enthusiast
5 - Automation Enthusiast

Thank you for the quick reply! I have shared our base with you.

Some additional information
- We restored the snapshot from several hours earlier and the fields were correct.
- When we created a copy of the base, we were able to change the field type. We created copies both in free and paid workspaces and had the same result.
- When we remove and readd the sync, it still would not convert. 
- When we created an identical field and synced that, it still would not convert.
- We tried removing all dependencies from the table and then changing the type. Still no luck.
- We added new link fields to other items and then linked those and they worked. We suspect it didn't like the current link we are dealing with because it was self-referential to the same table.

In the shared base the table is "Team" and the field is called "Ops Manager Region (Link const)". We have temporarily created a local copy of that field called "Ops Manager Region (Link const) copy"

Thank you again for investigating! 


Thank you for the detailed information @stephenheindel

We identified an issue on synced fields that are converted to self-referential links, and the issue should be fixed now. Let us know if you encounter the issue again!