Re: API Quota - Map Block - Google Developer Console has no quota

1236 0
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi everyone,

I’m using the map block, and have about 5,500 lines to map. At first I tried doing this without setting up billing in Google Developer Console, so naturally I hit the daily limit of ~600 or so and work stopped.

So I went and finished my account, added good billing, deleted old expired cards (I read somewhere this can be an issue even if not primary), and went ahead and refreshed the map… stops after a few hits. Still won’t proceed.

I waited hours (figuring maybe it takes time for Google to realize your billing is set up), and no dice still.

I tried creating a new API Key, then using that new key now that billing is complete in Developer Console, no dice.

I checked quota settings in Google API, it’s unlimited per day and 5,000 per minute, yet I can’t get more than ~3-5 out of my remaining ~4700 to complete each time I click to retry.

I opened a ticket with Google but I haven’t had a response yet to the details I submitted, they did ask me for code to check why this is happening and opened a ticket #, all I could give them was details on the tool (since I can’t exactly pull the code for Airtable’s map block to share), no response yet to that after a day.

Anyone else have issues with Google Developer Console still giving you free quota limits after your account is set up? Anyone resolve this successfully? To repeat I have the account complete, billing set up, no expired secondary cards, no quota limits that should affect this, and even tried a 2nd new API key created after all that was done. I have enough free credits on the account to pay for ~300,000 API calls before it should even hit the active billing card too. No dice.


3 Replies 3
4 - Data Explorer
4 - Data Explorer

Hi Orin!

I’m having the exact same issue.
Were you able to resolve this?


Same here. Seems like this is a common issue with Airtable’s Map block.

4 - Data Explorer
4 - Data Explorer

I am having this issue too. Has anyone found a solution?