Help

Cannot Share Interface to Read Only Access Viewers

Topic Labels: Interface Designer
Solved
Jump to Solution
1344 7
cancel
Showing results for 
Search instead for 
Did you mean: 
Aaron_Reynolds_
6 - Interface Innovator
6 - Interface Innovator

I have a Pro account, but want to allow some users to have Read Only access to an Interface I have created. I did the Share, but it doesn't show up for them on their login page anywhere we can see.

Is there something I am missing to get them to view the interface?

1 Solution

Accepted Solutions
Valentino_Escal
7 - App Architect
7 - App Architect

Hi @Aaron_Reynolds_ 

To fix this I will recommend the following steps:

Step 1: Take them out as a read only user on the interface and resend them the email so they can access the interface again. You can do this on the screenshot 'Invite' and click 'Manage access'.

Step 2: Make sure they understand that all interfaces that are shared are not located in the 'All Workspaces' tap and you have to click 'Home' instead.

Step 3: Repeat for any other interfaces you have shared with them.

I have included screenshots below so you/they can understand where the interfaces should be located! 

I hope this now fixes the problem 👌

Note: the screenshot 'Invite' shows how to invite them via email. 'Workspaces' shows the interfaces are not located there. 'Home' shows where the interfaces are shared.

See Solution in Thread

7 Replies 7
Valentino_Escal
7 - App Architect
7 - App Architect

Hi @Aaron_Reynolds_

That depends on how you are sharing the interface with them. Are you inviting them by link or email? Either way they will have to register to be an Airtable user to view the information.

If you are inviting them by email, they will receive an invite to the Interface and login to Airtable to view the Interface.

If you are inviting them by link, you will need to give them the URL link to view the interface. Hope this clarifies the issue for you!

Aaron_Reynolds_
6 - Interface Innovator
6 - Interface Innovator

@Valentino_Escal 

The user has an Airtable account, but when they login they don't see a link to the Interface.  They are available to choose as a Collaborator on a few bases I have them setup as Read Only, but none of the bases show up in their list.  Here is the interface though I have them setup on in first image.  And then in second image is their login and no interface or bases show they are setup as Read Only.

Aaron_Reynolds__1-1699539899397.png

 

Aaron_Reynolds__3-1699539934068.png

 

Valentino_Escal
7 - App Architect
7 - App Architect

Hi @Aaron_Reynolds_ 

To fix this I will recommend the following steps:

Step 1: Take them out as a read only user on the interface and resend them the email so they can access the interface again. You can do this on the screenshot 'Invite' and click 'Manage access'.

Step 2: Make sure they understand that all interfaces that are shared are not located in the 'All Workspaces' tap and you have to click 'Home' instead.

Step 3: Repeat for any other interfaces you have shared with them.

I have included screenshots below so you/they can understand where the interfaces should be located! 

I hope this now fixes the problem 👌

Note: the screenshot 'Invite' shows how to invite them via email. 'Workspaces' shows the interfaces are not located there. 'Home' shows where the interfaces are shared.

Aaron_Reynolds_
6 - Interface Innovator
6 - Interface Innovator

@Valentino_Escal 

I am much closer as they can now see the shared bases I have them in under Home.  They still don't see the Interface so I am trying to remove them like you said to add back.

When I am on the Manage Access screen (my picture 1 above), I don't see how to remove anyone from the interface.  I see the "Read Only" drop down and it will let me change the type of access, but none are to remove.

Ideas?  Appreciate all the help!

Here is what I see as options in dropdown:

Aaron_Reynolds__0-1699567306985.png

 

Hi @Aaron_Reynolds_ 

Ok cool! Good to know. This should clarify the issue 👇

Step 1: Click Share on the top right of the Interface.

Step 2: Click Manage Access

Step 3: On the read only collaborator/s, click the box where it shows their permission level and click remove access.

The PNG's below show have the three screenshots how to do it. 

Let me know if this fixes it!

@Valentino_Escal 

All figured out!! Thank you!

My issue was the person also had Read Only access to the full database so I can't just remove the interface.  I do see what you showed to remove though now on others I have added to only the Interface.

Again, thank you!

Valentino_Escal
7 - App Architect
7 - App Architect

Hi @Aaron_Reynolds_ 
Your welcome!

Ok that makes total semse..

Happy to help out and that you got it all sorted 👌