Help

Welcome to the Airtable Community! If you're new here, check out our Getting Started area to get the most out of your community experience.

Cells don't update on view change

Topic Labels: Views
Solved
Jump to Solution
664 4
cancel
Showing results for 
Search instead for 
Did you mean: 

Hi,

I’m using a function to check for how long people had registered with my group.
It’s working like a charm.

DATETIME_DIFF(TODAY(), {Position (since)}, 'days')

On the screen below, you can see it works great. It’s all good.

01

But when I change the view, the same cells aren’t updating… What am I missing? What do I need to do to see it updated alone?

On the screen below, you can see it’s not displaying what was entered on the main view.

02

1 Solution

Accepted Solutions

No need to duplicate data. You already likely have the same records in both views, but as @kuovonne pointed out, they’re in a different order. That order is controlled by a variety of things. Notice the different setup between your two views:

  • The “Manage: all” view is sorting by two fields, one of which is the primary field.
  • The “Group: active” view also has two sorts active, but it’s also grouping by one field, plus there’s a filter active.

Grouping means that records will be grouped by the data in a specific field (in this case, the {Status} field). Filtering means that only records matching certain conditions will be visible.

In your “Manage: all” view, the top record’s primary field says “Adapting”. When you change to the “Group: active” view, that “Adapting” record might still be there if it meets the filter criteria. If so, its position in the list will depend on how it’s being affected by that view’s grouping and sorting options.

Did you make these views yourself, or did someone else set up the views for you?

See Solution in Thread

4 Replies 4

Because when you change views, the data is presented in a different order, and the cell in the same area of the screen actually refers to a different record.

You may be familiar with how spreadsheets work, but Airtable is not a spreadsheet. Airtable is a database, not a spreadsheet.

So how to do it the right way please?
Do I need to enter everything twice on my two views?

There must be a way to duplicate the content without the necessity to enter the data twice.

No need to duplicate data. You already likely have the same records in both views, but as @kuovonne pointed out, they’re in a different order. That order is controlled by a variety of things. Notice the different setup between your two views:

  • The “Manage: all” view is sorting by two fields, one of which is the primary field.
  • The “Group: active” view also has two sorts active, but it’s also grouping by one field, plus there’s a filter active.

Grouping means that records will be grouped by the data in a specific field (in this case, the {Status} field). Filtering means that only records matching certain conditions will be visible.

In your “Manage: all” view, the top record’s primary field says “Adapting”. When you change to the “Group: active” view, that “Adapting” record might still be there if it meets the filter criteria. If so, its position in the list will depend on how it’s being affected by that view’s grouping and sorting options.

Did you make these views yourself, or did someone else set up the views for you?

Oh boy, I was just working on the wrong line…
Thanks for your kind reminder @Justin_Barrett, it’s all good now.

Airtable rocks!