Help

Date field rounding up when "include time" is not selected

Topic Labels: Dates & Timezones
259 3
cancel
Showing results for 
Search instead for 
Did you mean: 
jordan_riley
4 - Data Explorer
4 - Data Explorer

I have two date fields that sync from an Outlook calendar. Because most events on that calendar are full-day events, they have an end time of 11:59 PM. This is what it looks like with "include time" selected:

jordan_riley_0-1719582106861.png

...and this is what it looks like toggled off.

jordan_riley_1-1719582162154.png

I reviewed this similar question, where it turned out to be a time zone issue, but that doesn't apply here as the time zone settings aren't accessible if you don't show the time. I'd prefer to hide the times for the sake of tidiness/reducing visual clutter. Is there a way to fix the rounding issue without creating a separate formula field?

3 Replies 3

Weird. I tried replicating it here but it seems to work fine so I reckon there's something specific to your data

Screen Recording 2024-06-29 at 11.03.36 AM.gif

If you could provide a read-only invite link to a duplicated copy of your base with this issue I'd love to take a look at it.  Extra formula field sounds like it'd solve your problem the quickest though!

Interesting--I'm guessing it's tied to the fact that the data is imported from Outlook, since you weren't able to duplicate it with a regular date field. Thanks for trying!

berlingroft
4 - Data Explorer
4 - Data Explorer

You can try using a formula to extract the date portion from your original date field, regardless of the "include time" setting. This way, you'll always have the intended date without rounding.