Help

Re: Empty record showing up when grouping by single select field?

Solved
Jump to Solution
583 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Stan_Zukowski
4 - Data Explorer
4 - Data Explorer

We have a base that lists all of our dealers’ contact information, including state.

State is a single-select field, with all states listed, just to make it easier for people to enter the correct state, and also to ensure consistency of the state abbreviations.

I created a grid view grouping our dealers by state, which worked fine. However, at the top of the list is an “empty” record – and I can’t figure out why.

I looked in the single select list (where you manually input the data) and didn’t see any blank or empty fields.

I also looked at all the individual dealer entries to make sure each one has a state selected, and they all do.

Any ideas why that empty field is appearing?

image

1 Solution

Accepted Solutions
Databaser
12 - Earth
12 - Earth

Hi @Stan_Zukowski

When you “group” based on a select field, you get the option to “show groups with no records”. This lets you see the options from your select field that haven’t got any records yet. When you activate this option, it also lets you have an option to create a record under a new option in your select field.

You can (de)activitate that option via the “Grouped by x field” option.

image

See Solution in Thread

4 Replies 4
David_Presley
4 - Data Explorer
4 - Data Explorer

It could be there is an extra blank record in your base. If you stop the grouping and just look at your data in a grid view, then sort the “State” column by A-Z. The empty record should come straight to the top.

@Stan_Zukowski If you ungroup and then regroup, is the empty group still there? You might need to reach out to support@airtable.com and let us know what they say.

Databaser
12 - Earth
12 - Earth

Hi @Stan_Zukowski

When you “group” based on a select field, you get the option to “show groups with no records”. This lets you see the options from your select field that haven’t got any records yet. When you activate this option, it also lets you have an option to create a record under a new option in your select field.

You can (de)activitate that option via the “Grouped by x field” option.

image

That was it! Thank you!