Help

Error message when try adding a linked record

Topic Labels: Data
3020 11
cancel
Showing results for 
Search instead for 
Did you mean: 
Paintedhouzz_LL
6 - Interface Innovator
6 - Interface Innovator

When I try to add a record in the linked record field I get an error message "You are not permitted to perform this operation". It does not happen in all ‘link a record’ field but in some, randomly. The issue is occurring on my iPad and iPhone apps. It seems working fine on Safari browser on my Mac. I am the owner of the base. It started happening about 1-2 weeks ago.

Any suggestions? Thank you!

11 Replies 11

Hi @Paintedhouzz_LL,

Hmm somehow Airtable thinks you don't have permission to edit the linked table as selecting linked records updates values in both tables. Have you tried replicating the error in the browser app? That might rule out if it's a bug in the iOS app.

-Stephen

It works fine on Mac Safari browser.  

Ah could be a bug 😞 You might try contacting Airtable support to assist here

https://support.airtable.com/docs/contacting-airtable-support?contact_support=true

@Juliana 

Thank you! I just did. Let´s see…

Thanks for alerting me of this @Stephen_Orr1, and thank you @Paintedhouzz_LL for surfacing this behavior—it definitely sounds odd to me as well! If it were consistently producing this error I'd think that table editing permissions were at play, though due to the immediacy of the error after selecting the linked record field and isolation to iOS apps, it sounds like something else may be going on. I see that one of my colleagues is currently on the support ticket, so we should hopefully have the cause pinpointed shortly. Thanks again for your assistance during this process!

RnJ
8 - Airtable Astronomer
8 - Airtable Astronomer

I have been having the same issue.

 

Tom_at_CellSEP
4 - Data Explorer
4 - Data Explorer

I am having the exact same issue. Only on iOS app version v9.4 (8475). 

To troubleshoot: I created multiple linked tables to test other linked fields. That went without any issue. Only this one specific table (not synced) is showing the popup. 

 

Calvin_Young2
6 - Interface Innovator
6 - Interface Innovator

Same issue here.  Multiple accounts, multiple iPads, permission levels, etc... there's just one linked field that seems to be cursed.  I even tried duplicating the field, re-linking all the dependencies, and it still gives an error.  It's definitely not an issue with permissions since the error only occurs on the iOS app on the iPad and it specifically prevents me from adding linked records.  If a linked record exists, I can delete it.  

Anecdotally, it seems to work on my iPhone -- but the issue seems to be inconsistent so I don't know if that's a reliable signal.

halffrozen
5 - Automation Enthusiast
5 - Automation Enthusiast

Has there been any update to this? We have interfaces setup for employees also not having full Base access with iPhones that are having to select a specific record, and are unable to. Like others also, they can select other records in other interface pages, however of course, the specific page we need them to utilize, isn't working.