Help

Form page visible via shared link does not reflect the changes in the form view

Topic Labels: Sync
440 1
cancel
Showing results for 
Search instead for 
Did you mean: 
jakacki
4 - Data Explorer
4 - Data Explorer

Hello,

Your help will be appreciated with the following issue:

I have created a form and shared it via a link ("Share form" button in a form view). I need to fix typos in the form description. When I change the content of the form (in the form view), the webpage displayed via the shared link does not change accordingly. Same for the page displayed via the "Open form" button (actually this is the same URL as the shared link). I am under impression that it should.

I recall that several weeks ago Airtable seemed to be working differently, i.e. the changes made in the form view were propagated in real time to the webpage reachable via the shared link (and via the "Open form" button).

I do not believe this is a problem with my local browser cache, because others who open the form page on their computers for the first time ever, still see the outdated form (while their browsers did not have a chance to cache anything yet).

Am I missing something, or am I seeing a bug in that the changes to the form design do not propagate in real time?

I was hoping that maybe some edits to the form configuration will accidentally trigger refresh of some internal data structures in Airtable and effect the update of the shared link page, but what I tried did not work for me (I toggled these configuration options on and off: "Restrict access to an email domain", "Restrict access with a password", "Stop accepting new responses"). I have not tried re-generating the shared link, because that would invalidate the link that I have already shared with a large public.

Thank you for reading that far. If from my description you see where I may be making a mistake, please kindly let me know. Similarly please let me know if you can think of any workaround (that would not require re-generating the shared link).

Many thanks.

Greg

1 Reply 1
ScottWorld
18 - Pluto
18 - Pluto

This sort of problem is typically a user error.

All changes to forms are displayed instantly in real time, so be sure that you're using the proper link for the proper form for the proper base. Many users are editing the form in an outdated base or a duplicate base or a recently-restored-from-the-trash base. Other users are editing the wrong form view,, because they don't realize that they have created many different form views in their base.

And remember, if it's an interface form, you have to publish your changes first before the changes will show up.

Alternatively, think about migrating away from Airtable's forms altogether and using Fillout instead. It's 100% free.

Airtable's forms don't have a lot of built-in functionality, so they're not really the best forms that we have available to us. If you're looking for best & most advanced & most feature-rich forms for Airtable which are 100% free to use, I would highly recommend using Fillout.  It provides all the form features that all of us have wanted Airtable to provide us for the last 8 years.