Has the URL format for attachments changed in the last 24 hours?

3257 11
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

It would appear that the URL for attachments is no longer showing the file extension, and the location has changed a bit as well. It’s breaking things for me :sob: Wondering if this is a bug or a new way attachments are being handled. Any thoughts on this appreciated.

11 Replies 11

Hi @iamlaureen ,

As part of a broader effort to improve the performance, stability, and security of our attachment fields, we recently made some changes to our URL formats and paths. We’re truly sorry that this has broken your workflow. Not communicating this product change to our users in advance was a misstep and this isn’t the experience we want our users to have. In the future, we’ll do a better job of communicating any changes that could have a significant impact on your workflows.

I’d love to see if I can help you with a workaround—If you have a moment, would you mind giving us a little more context for how you were using the old URL format as part of your workflow? Are you using the API to get the URL, or some other method? What specific elements of the old URL format were you trying to parse out, and why? If it helps, you can still find the original filename of the attachment in the filename field when using the API.

Hi Katherine pls have a look to this topic: Attach File with Zapier Email

I have the same problems, the attachments in emails which I send with zapier, can not be opened anymore because the fileformat information seems to get lost.

Hi Katherine, specifically, i was using the file path to 1) perform remote file uploads via the windows upload dialogue. That unfortunately wont accept the link, since there is no longer a file extension, and it says its an unknown file type and 2) to apply image transformations through cloudinary, but we may have that worked out. Im not quite sure yet… But essentially, its losing the file extension that is creating the trouble. In the first case, its through the API. in the second case, its via formula fields. Any guidance you can give would be appreciated :slightly_smiling_face:

Could you clarify if you are planing to change this again, or will it stay like that. It’s a real big problem for us. We just cannot send attachments (like invoice etc.) by mail with zapier anymore…

Hey there, still available to help with getting the file extensions back via API? We’ve got 500+ users waiting on this functionality to be added back #helpplease :slightly_smiling_face:

Hi @iamlaureen,

As mentioned before, we recently rolled out some changes to improve the performance of our attachment fields. After receiving feedback from you, @Avi_Doe, and others, it’s become clear that a number of our users were relying on the ability to get attachment names and file extensions from the API, and that this change interfered with our users’ workflows.

Following internal discussion and careful review of your feedback, we’re pushing out another change which will re-add file extensions and a sanitized version of the filename to URL attachments. This change will also keep various other performance, security, and stability improvements that the previous change introduced. This should preserve the workflows that you and other users previously made (which rely on being able to get file extensions from the API) while also improving the attachment experience overall. We expect this change to roll out to everyone in the next few days.

As promised, we want to be transparent with you about any changes we make to the product that could have an impact on your workflows. Airtable believes strongly in encouraging people to build their own custom solutions rather than relying on out-of-the box products, and we know that being caught off-guard by unexpected changes to our functionality can be a discouraging experience.

Our product team strives to carefully and methodically think through all of the potential effects that a change or a new feature might have on all of our users and their unique, diverse workflows. Not foreseeing the negative impact that the previous change would have on your workflows was a mistake, and it’s one that I hope we can learn from going forward.

Please let me know if you have any questions, and hopefully this new change will allow you to get your workflows back online again!


thank you so much for your reply, and this action. We really appreciate your hearing our needs and acting swiftly to rectify the situation. we’ll keep an eye out for the update over the next few days :slightly_smiling_face:

6 - Interface Innovator
6 - Interface Innovator

@Katherine_Duh thank you for the reply, your support also got in touch with me. That are also very good news with the security improvements you are planning for the attachment fields, I am very curious about it!

Hi Katherine,

Do you have any documentation on the changes? Seems like I still have the file extensions, but maybe location change has broken stuff for me. I wrote my API code a couple years ago and it worked fine until about 8:25 this morning. I store images in AT, one per record, and use those to populate excel to print item ID tags. Now my images don’t work.

Also, just a thought… You probably have server logs showing what users are accessing AT through the API. You could send out some advanced notice and documentation before breaking our code.