Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

Help with Airtable to Slack to Zapier to Airtable

Topic Labels: Integrations
1123 1
Showing results for 
Search instead for 
Did you mean: 

I am looking to update a linked field in an Airtable table automatically and recognize this can only be done via 3rd party integration currently (i.e. Zapier or Integromat).

Also, as Airtable doesn’t support webhooks, I am doing the following:

  • Turned on Slack notifications and am sending change notifications to a dedicated Slack channel
  • Created a Zapier Zap to use a Slack notification as trigger
  • I then have an Airtable Find action to find the relevant Airtable record using info from the Slack notification
  • I then have an Airtable update action where I am concatenating two fields into 1 linked field, separated by a dash. “Field A-Field B” I am reading this info using a search value from the Airtable find action step.

It’s working fine with one issue. When the Update step tries to update the Airtable record it’s putting the linked field id in the field vs the text value of the linked record.

From my tests in the zap, everything before this last step looks fine. I see the text value vs the actual ID value. But the update itself puts the record id into the field, which generates an error.

Any help much appreciated!

1 Reply 1

I was able to figure this out and thought I would share my trials here so others can learn from my mistakes. It turns out I was doing multiple things wrong.

My scenario is that I was trying to take two linked fields, concatenate these together, and then use this calculated value to update a third linked field.

I’m using the Slack notifications feature as an initial trigger and then wanted a Zap to go find and update the record that initiated the Slack notification.

Issue #1: Reading in Linked Field Values

My first issue was reading in Linked Fields. When I tried to use these fields in the Zap, it became clear Airtable was passing the Linked Record ID versus the actual Field value.

To work around this, I created two new formula fields and set the formula to pull in the values from the Linked fields. I named these with a “Zapier” prefix to easily distinguish from the original fields.

Problem solved.

Issue #2: Trying to Use these Values to Update the Third Linked Field

Apparently, you can’t just put a text value into a linked field via an update. You have to pass it the actual Record ID from the linked table.

So to get this, in the linked table, I:

  • Created a new formula field set to return Record ID.
  • Created a new formula field that read from the Table’s primary field in a nice, text field that Zapier can use in a Find. Not sure if I really needed this or not, but I did it anyway lol.

I then added a new Zap step to search my linked table and used a Search Formula to find the right linked record using concatenated values from my prior step. This now gives me access to the Record ID for the right “to be linked” record from the linking table.

Now I had everything I needed.

For my final step (which is the Update), I used the linked table Record ID to populate the third linked field.

It’s kind of ludicrous, but it works!