Help

Re: How to stop creating new records automatically in linked table

712 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Cheng_Chang
4 - Data Explorer
4 - Data Explorer

When you input a not existed value in a linked column. A new record would be created in the linked table. How can I stop it from creating new records automatically?

11 Replies 11

Welcome to the community, Cheng! :grinning_face_with_big_eyes: This feature can’t currently be disabled. It’s always going to create a new record in the linked table if the item you enter doesn’t already exist.

Can you describe more about your use case where you wouldn’t want that behavior to happen? Maybe there’s another way to structure your base to achieve what you want.

Thanks for your response Justin.

I need to copy user names from a Google drive spreadsheet. And some names may be slightly different from the one in the linked table. I would prefer airtable leaving wrong names as blank rather than creating a new record in the linked table. Is there any solution?

You can import to a different column, edit the usernames if needed then copy the whole column to the link column after processing.

Regards,

Alex

Axel_Bock
4 - Data Explorer
4 - Data Explorer

incredibly annoying! Please make this a feature, I’m editing a table for 1 hour now and I don’t actually know how many accidently created rows I had to delete in that time. PLEASE consider this feature request, @Justin_Barrett - or if that changed (I couldn’t find anything) please tell me how to do this. that would be a very simple checkbox which would smoothen my editing experience greatly.

Welcome to the community, @Axel_Bock! :grinning_face_with_big_eyes: I’m just a fellow user like yourself. My badge & label just indicate that I talk a lot, and sometimes it’s helpful. :winking_face: While there is a feature requests category that Airtable staffers peruse on occasion, the most reliable way to get your request in front of Airtable devs is to contact Airtable support directly.

Make the primary field of the linked table a formula. Airtable will not be able to create a new linked record automatically when the primary field is a calculated value.

Thanks I was trying the reverse of this post - to allow creating linked records to happen as they were not for me - I’d created formula ‘1st column’ items and I couldn’t new records and was wondering why - many thanks

Any idea why I am getting duplicate records when I am linking from one table to another. The record exists, but AirTable is creating a record like it does not. Am I doing something wrong?

Hi,
Check extra spaces in field value.
If not, try to copy-paste both values into some record text fields and compare by formula (create new temporary table for that, if needed) . Sometimes it display value in a strange way, where & char present in text, containing line breaks.

Anyway, it’s a very useful feature, which can be used for grouping, find and mark duplicates, bulk dedupe or compare two arrays of values.
Another way to stop creating new records, besides calculated primary field, usable for temporary use before copy-pasting into link field - to set table permissions ‘Who can create records’ to ‘nobody’

Welcome to the community, @Colleen_Scollans! :grinning_face_with_big_eyes: Did the tips from @Alexey_Gusev help? If not, could you please share more specific details about your base setup and the steps that you’re taking that lead to the issue?

Thanks for the tip @kuovonne ! You always have the angle 🙂