Help

Re: How to stop creating new records automatically in linked table

2328 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Cheng_Chang
4 - Data Explorer
4 - Data Explorer

When you input a not existed value in a linked column. A new record would be created in the linked table. How can I stop it from creating new records automatically?

13 Replies 13

Welcome to the community, @Colleen_Scollans! :grinning_face_with_big_eyes: Did the tips from @Alexey_Gusev help? If not, could you please share more specific details about your base setup and the steps that you’re taking that lead to the issue?

Thanks for the tip @kuovonne ! You always have the angle 🙂

OmarElsiefy
4 - Data Explorer
4 - Data Explorer

Hi @Justin_Barrett & @kuovonne not sure if you might have any idea as to how to fix this.

I have a base with multiple linked tables within, one of these tables has compiled info that I am syncing to another base.

Since the vendor name is synced it is typed exactly the same across all tables and bases. I have an automation running to also link two tables together on the second base. However, even though the name is EXACTLY the same it doesn't find it and ends up creating a new row which messes up the whole flow.

I tried using record ID but since I sometimes have rows linked to multiple vendors, hence multiple record IDs I can't use it to run the automation. Is there anyway to fix this? I'd highly appreciate any insights.

You should be able to use record IDs when linking records. However, when working with synced tables, there are two sets of record IDs, the original record IDs in the source table, and the new record ID in the synced table. You cannot directly use the original record ID to link to the synced record.

As for why you are getting a duplicate record when linking the two tables in your automation, it is hard to diagnose the issue without seeing the setup of the automation and the actual data. There can be issues if primary field values are not 100% unique. There can be issues if primary field values have commas, quotes, or other special characters in them. There can be issue with how you are finding the records.

Another option that you can try is to change the field type of the synced link field from a text field back to a linked record field type.