Re: Random quotation mark in calculated field?

3254 0
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast
  1. I have a field in TableA called “ProductSKU” which is a primary field that concatenates some data from other fields in TableA. The formual is: LEFT(Description,10) &"-" &FinishCode &"-" &Model

  2. I have a field in TableB called “SelectKit” that is a link to “ProductSKU”.

  3. I have a third field in TableB that concatenates data from the “SelecKit” field. The formula is: LEFT({SelectKit},5)

Now, that we’ve established that. I have found that SelectKit is arbitrarily entering a single quotation mark as in " just before the text that is being pulled from “SelectKit”. This only happens in one case. I’ve checked all the fields from every other table and there is NO quotation mark entered in a field. I’ve checked the formulas and they all appear correct anbd otherwise working, except for one entry.

Why is this question mark being entered??

28 Replies 28

I also recently ran into a case of unexpected quotation marks in copy/pasted data. In this instance the culprit was an extra space character between the parts of a two-word field name. To make matters even more confusing, in grid view the doubled character is invisible, as white space ordinarily is collapsed automatically by the browser. Only if one expanded the record did the additional space become even perceivable.

Caproic Acid rendered as Caproic Acid",1
but Caproic Acid would render as Caproic Acid

6 - Interface Innovator
6 - Interface Innovator

This thread was very helpful, so thank you everyone.

If like me there is a reason why you can’t change the use of commas in a text field, you can use the following simple formula to remove the double quotation marks.


SUBSTITUTE(Field,’"’,"") didn’t work for me but this did—SUBSTITUTE(Field,""","")

I’m having trouble getting this to work for me. The name of my concatenated field that I’m trying to get rid of the quotes from is, “Agency, Program, Module.” I have tried the below combinations based on these comments, but neither worked. Do you know what I’m doing wrong? The error message I receive says it’s an invalid formula and so it doesn’t save.

SUBSTITUTE({Agency, Program, Module},’"’,"")
SUBSTITUTE({Agency, Program, Module},""","")

This worked for me; try copying and pasting my formula as displayed below. You may have gotten bit by the Airtable formula editor’s dislike for curly quotes, which often get carried over if copying and pasting formatted text, such as text not inside a code block on these forums.

SUBSTITUTE(Name, '"', '')

That worked great!! Thank you!!

I cant seem to get this to work its giving me an error. Im trying to apply the formula to the lookup field via fx

Figured it out, it was returning error becasue I was trying to modify the string as a fx of LOOKUP. Thanks!

This worked! thank you

6 - Interface Innovator
6 - Interface Innovator

@Casey_Kleiman & @Sam_Aronson This is an issue I’m currently having with commas and quotation marks… where do you insert that substitution text in your formula? Mine currently reads:

DATETIME_FORMAT({Date of Donation}, ‘M/D/YYYY’) & " — " & IF({Donor Account}, {Donor Account},{Company account})

And it’s pulling like this:

Screen Shot 2020-09-21 at 8.20.30 PM