Search Results not complete. What's the remedy?

Topic Labels: Extensions
1240 5
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Dear Airtable Community,

We are evaluating if Airtable were a great choice to store our knowledge base. Until now, I was pretty convinced, but now I came across a pretty strange phenomena. We have a database of relevant articles, where we have a field for the type of media and one for tags.

When I search for "Resilienz" I get 126 records (see screenshots) in the relevant table. And out of these results most of them have the media type "Artikel".

However, when I then search for "Resilienz Artikel" I only get one Article (see screenshot). How is that possible?

Either this is a very strange bug or the search is really basic as it cannot search through multiple columns at the same time?


Also, if I use the syntax from here

using "stichworte: Resilienz medientyp: Artikel" I get even zero results (see screenshot).


Does anyone know what is going on here?





5 Replies 5

Hm, that's indeed weird.  I attempted replicating your issue but wasn't able to; if I were you I'd open a support ticket I think

Screenshot 2023-01-26 at 9.53.39 PM.png
Here's a link to the base in case you want to compare the setup

5 - Automation Enthusiast
5 - Automation Enthusiast

Thanks for the quick response and trying to replicate it. It's odd. When I open your table I get the same result as you. The filter function works with your table (see screenshot)


However, one thing I don't understand is if I type just 'Option 1 Option 4' I would expect the search result to be the same (the search function matching any entries containing at least either or or both. At least if I do '"Option 1" "Option 4"' (the search words in quotes) I would expect the search to be able to give me all entries containing both keywords. Is this the same with you?

This seems strange for a search functionality to me. And it is useless for our use case. We need to be able to write multiple keywords and see all entries in the database containing all these keywords.



4 - Data Explorer
4 - Data Explorer

It seems to be a glitch.
I tested with the language settings of search ( see screenshot)
At first, in case the field name was an English term, like Select, Option or Type and in the search settings the language was English. It worked fine.
But the moment I changed the fieldnames into Dutch terms, I did not get any result.

However, changing the language to German, or French or even Japanese made it work fine again.
But oddly, after a few times back and forth, it all worked regardless the language. Even after refreshing the database. Hope it works for you as well. If so, maybe opening a ticket is a good idea.


Hey Mirjan,

Thanks for the tip. I just tried it out and played around with the language and also with the grid view / all records view in the search extension and somehow then filtering suddenly started working.

That is very odd. Thanks for the tip, at least now this seems to work.

The other thing I am still confused about is why I am not able to search through the whole database by typing multiple keywords and have the all record be shown that contain all of these keywords.

For example now if I type: "Stichworte: Resilienz Medientyp: Artikel" I get 102 results (filtered from the 126 if I only type "Resilienz" or "Stichwort: Resilienz" (in this specific table the number of results is the same))


but when I type: "Resilienz Artikel" I get exactly one result. For me it doesn't make sense that the search extension doesn't show me the same results (or at least as many results as with the search above as the keywords could also be contained in other fields of the record) when I type two keywords instead of when I filter by column.




Hi Jonas,
I checked the topic on the Airtable site. It seems that you cannot have nested search requests. The advice is to create a view with a filter and then perform a search. Check this pages, first topic under FAQ:
maybe a nice feature request, though 🙂