Help

Welcome to the Airtable Community! If you're new here, check out our Getting Started area to get the most out of your community experience.

Typeform to Airtable zapier integration - Problem with uploading attachments / images

Topic Labels: Integrations
Solved
Jump to Solution
1123 6
cancel
Showing results for 
Search instead for 
Did you mean: 

Connected typeform to airtable through a zapier integration. Text data, single select options work and is moved. Problem is the uploaded image / attachment from typeform comes up empty in my airtable. Anybody with the same problem?

Screenshot of attachment being uploaded in typeform:
airtable_typeform_zapier2

Screenshot of table with missing attachment data:
airtable_zapier_typeform

1 Solution

Accepted Solutions
John_Young
5 - Automation Enthusiast
5 - Automation Enthusiast

Solved!

Solution:

  • Turns out I’ve been choosing the wrong field. My initial assumption was that I would choose the typeform field which would return the attachment in Airtable, as how I would do with the text fields. Problem was that the data always came up empty.
  • Well, there’s an option there in Zapier that notes a file that “exists but not shown” Changed the option to that and now everything works.

See Solution in Thread

6 Replies 6

Hi @John_Young, and welcome to the community!

Yes, and broadly for many integrated process. This is a known bug discussed here, here, and here.

@John_Young Are you sending the URL of the attachment to Airtable? You can’t send the binary attachment file, you have to send the URL.

I did not see that possibility. :winking_face: Good catch.

I am not sending the URL attachment. I was assuming it would just send the file directly to airtable as an attachment.

Awesome! How would I set that up in that case? How can I source the uploaded image on typeform as a URL?

Thanks for the warm welcome! :slightly_smiling_face: Hoping to solve this soon

John_Young
5 - Automation Enthusiast
5 - Automation Enthusiast

Solved!

Solution:

  • Turns out I’ve been choosing the wrong field. My initial assumption was that I would choose the typeform field which would return the attachment in Airtable, as how I would do with the text fields. Problem was that the data always came up empty.
  • Well, there’s an option there in Zapier that notes a file that “exists but not shown” Changed the option to that and now everything works.