Help

Re: Automation to update status of a linked record?

Solved
Jump to Solution
1114 0
cancel
Showing results for 
Search instead for 
Did you mean: 
MicahM
5 - Automation Enthusiast
5 - Automation Enthusiast

This seems like it should be well documented but I'm having a devil of a time finding a clear example. 

Goal: When a new Activity is created with a Type of "Posting Closed", I want to update the linked Applications so that it's Status is "Recently Closed".

Table structures: 

ApplicationsActivities
Title [text]Type [single select]
Status [single select]Date [date]
Activities [linked record] Job Postings [linked record]

I'd really appreciate some 📸 screenshots of a working sample automation configuration too.

Thanks!

1 Solution

Accepted Solutions
MicahM
5 - Automation Enthusiast
5 - Automation Enthusiast

Awesome, thanks Stephen, that fixed my error!

For posterity, here's the correct automation for updating a status on a (single) linked record:

MicahM_0-1685552864403.png

However, my initial configuration was generating an error on the "Update Record" action (which Stephen solved). To fix it, I had to set the display of the Application to ID. It defaulted to "Name" and I guess that's why I was getting the "invalid input" message: 

MicahM_0-1685552657485.png

 

See Solution in Thread

6 Replies 6
Stephen_Orr1
10 - Mercury
10 - Mercury

Instead of using the "when record is created" trigger, use "when record matches condition." Then for your action, update record on the table containing Job Postings where the Record ID = the trigger record's linked record field (displayed as ID, not name) to your Job Postings table. Hope that helps!

Ok, yeah, I've run into an error doing this before. 

Creating the trigger works well and it is able to find an Activity that meets the expected criteria:

MicahM_1-1685376287188.png

However, when I create the Update Record action, specify the id for the linked Application record, and tell it to update the status, I get an error message that says invalid input

MicahM_2-1685376661959.png

Is this the automation flow you were suggesting, or did I miss something?

 

 

 

In your second screenshot, make sure the Application in the Record ID is set to display: ID

Hi,
Your configuration might work for a single linked record, but it's not accurate, as there might be several linked Applications. Linked field contains array of IDs and some time ago it was a common problem - how to use it as a single ID value. Now it's possible, but if you want to update all linked records, you should use Repeated group and then put Update action inside it. But if you are sure there is always only one linked Application, you may update is in a single action, as suggested.

MicahM
5 - Automation Enthusiast
5 - Automation Enthusiast

Awesome, thanks Stephen, that fixed my error!

For posterity, here's the correct automation for updating a status on a (single) linked record:

MicahM_0-1685552864403.png

However, my initial configuration was generating an error on the "Update Record" action (which Stephen solved). To fix it, I had to set the display of the Application to ID. It defaulted to "Name" and I guess that's why I was getting the "invalid input" message: 

MicahM_0-1685552657485.png

 

Awesome, glad that helped! Could you please accept my previous comment as the solution? 🙂 Helps my progression in the community here. Appreciate it greatly!