Help

Gmail Automation - Precondition check failed

Topic Labels: Automations
326 7
cancel
Showing results for 
Search instead for 
Did you mean: 
Ashley_Jackson
6 - Interface Innovator
6 - Interface Innovator

Building a simple library management system in AT.  Would like to send an automated email reminder to folks with books overdue.  Because AT doesn't allow sending emails to non-collaborators, I have to use the Gmail email action.  I'm running into this error causing repeated failed runs:  Precondition check failed.

I'm attaching screenshots of my automation overview and detailed shots of the Gmail portion.  Thanks for any help!

Gmail Action Settings - 2Gmail Action Settings - 2

 

Automation OverviewAutomation Overview

 

Gmail Action Settings - 1Gmail Action Settings - 1

 

Successful preview generated.Successful preview generated.

 

7 Replies 7

FYI: Airtable allows sending emails to anybody (not just collaborators) on the pro and enterprise plans. 

Yes, Sadly we are on the Business plan - whatever is between the free plan and the Pro plan 😞

Could you provide screenshots of the relevant tables (specifically the email field and email lookup field)?  If you could provide access to an example base that would be best

Your automation looks fine, so I would need to dig into your data setup to figure out what might be going wrong

Hi, I appreciate the help!  I felt like the automation was set up correctly, which only confused me more lol.  Here are the screenshots you requested with a bit of redacting to protect our reader's privacy!  I think you can see what you need to know, though!  Perhaps the issue is trying to use a lookup field for the email address instead of an actual email field?

This is the "readers" table which contains all the contact info for our readers.This is the "readers" table which contains all the contact info for our readers.

 

This is the "loans" table which looks up the email for use in the autoamation.This is the "loans" table which looks up the email for use in the autoamation.

 

Weird!  Your screenshots look fine to me too.  I was wondering whether there was a timing issue where the reader record wasn't linked to this record with the "Loan ID" yet when the automation to send the email ran, but that seems unlikely

Unfortunately without access to an example base with your automations and stuff set up in it I can't help further.  Might want to open a support ticket!

@Ashley_Jackson Airtable support can take a very long time (i.e. several weeks) to get back to customers who aren't on the Enterprise plan. In the meantime, while you're waiting on a reply from them, I would try automating your emails using Make's Gmail modules. If it doesn't work with Make either, then you know that there's something wrong with your Gmail account. If it works with Make, then there's something wrong in Airtable.

Alternatively, if your company has a budget to pay for an expert Airtable consultant to help you with your system, feel free to contact me through my website.

@TheTimeSavingCo 

I'm curious, why is it that you get to have a link to your website in your signature when I've been told by the moderators here that this is against "Community Guidelines"?