Help

Re: Access the URL of an Airtable attachment using a formula (after attachment update)

2008 11
cancel
Showing results for 
Search instead for 
Did you mean: 
christoph
6 - Interface Innovator
6 - Interface Innovator

Hello everyone,

Who can tell me the formula to get the attachment URL in the new https://v5.airtableusercontent.com/... format? 

The one below only returns the format https://dl.airtable... which no longer works.

 

IF(
AND(
{Attachment},
FIND(
",",
{Attachment}
) = 0
),
RIGHT(
LEFT(
{Attachment},
LEN(
{Attachment}
) - 1
),
LEN(
LEFT(
{Attachment},
LEN(
{Attachment}
) - 1
)
)
- SEARCH(
"https://",
{Attachment}
) + 1
),
IF(
{Attachment},
RIGHT(
LEFT(
RIGHT(
{Attachment},
FIND(
",",
{Attachment}
) - 1
),
LEN(
RIGHT(
{Attachment},
FIND(
",",
{Attachment}
) - 1
)
) - 1
),
LEN(
LEFT(
RIGHT(
{Attachment},
FIND(
",",
{Attachment}
) - 1
),
LEN(
RIGHT(
{Attachment},
FIND(
",",
{Attachment}
) - 1
)
) - 1
)
)
- SEARCH(
"https://",
RIGHT(
{Attachment},
FIND(
",",
{Attachment}
) - 1
)
) + 1
)
)
)

 

 

Thank you!

13 Replies 13

Try using an automation to grab the expiring attachment URL and paste it into a text field.  I'm curious what you're trying to do given that it expires in 2 hours though?

Not sure what you mean. The formula I posted above is able to grab an URL in the known format https://dl.airtable.com/... like it has been for the past 2+ years. The issue is that the URL does not work, even directly after the upload.

All I get is:

The link you're trying to visit is not available. Please visit our support center for more information.

I am using Airtable attachment URLs as part of my workflow to publish designs. An external application grabs the attachment file through the URL as soon as I trigger the process. I can do that within 2 hours of the upload or imply re-upload the files no another field as soon as I start the process assuming that this would generate a new link.

Yeap, attachment URLs from formula fields don't work anymore after the update; it's why I'm suggesting using an automation to grab the URL instead:

Screenshot 2023-05-01 at 1.35.44 PM.png

Ok, I'll give it a try. Would you mind sharing what you are showing a screenshot of and how to get there?

Hi - I've noticed that Page Designer has similar issues with Image URL at the moment - is this issue connected with Christoph's?

As shown in images attached, the image box in Page Designer shows a broken link instead of a logo, but even the screenshots in the Page Designer page from the Extensions collection show as broken links. Is everyone else having this issue?

Found it in the Automations setup. Seems to work! Thank you!

Yeah it should be, from my understanding any image links with "dl" at the beginning won't work I'm afraid

As a workaround you might need to create a new table with records that hold the images you use for your Page Designer, and then link them and use lookups to display those images.  You can then reference them within your Page Designer.  Not the most elegant solution, but it works

re: screenshots from the Extensions collection show as broken links
Hmm, I have no idea why that's happening and whether it's linked to this, but I can tell you I see the same thing you do!

Screenshot 2023-05-02 at 3.40.23 PM.png

Thanks Adam... We've always had a separate table just for the image attachments for Page Designer (as pictured below). Now it sounds like I'm going to need ANOTHER table just to lookup urls of images in THIS existing table? You're right - this is a very clunky workaround, and seems crazy for an internal extension to need this for such a basic function!

Airtable images6.jpg

Cheers,

Andrew

Oh nah, your existing table would work fine, you'd just need to add links to your data records to it:

Screenshot 2023-05-02 at 9.11.14 PM.png

Screenshot 2023-05-02 at 9.11.12 PM.png

And in Page Designer you can see that the lookup fields would be available for selection here:

Screenshot 2023-05-02 at 9.11.20 PM.png

And here's a link to the base if you'd like to check it out yourself

I'm hoping that I've missed something and that there's a better way to do it too honestly

Sir,

I'm missing why simply keeping the image in another table, then linking the destination record to the source record where the image is stored, and creating a URL Generation Formula doesn't work.  Could you please re-capture the Page Designer image above showing the URL you included in there for either image?  And I'm not catching what you're getting at with writing the automation above.  Thanks for your help.

Hi Adam - thanks for your help with this, and for putting together the sample template. I'm pretty bad with the link/lookup stuff, but will use your template and see if I can make it work in ours. Not really keen to have so many additional columns in our main table, but looks like the only solution for now. Thanks again!

Hi Dillon!  The URLs generated via formulas no longer will work I'm afraid. You can read more about it here, and here's the specific bit that talks about it:

Screenshot 2023-05-04 at 2.01.18 PM.png

> Could you please re-capture the Page Designer image above showing the URL you included in there for either image? 

Ah I'm not using a URL, just the lookup field itself:

Screen Recording 2023-05-04 at 2.02.33 PM.gif

That was so simple it made my head hurt 😲, thank you Adam!