Help

Commas for Numbers

Solved
Jump to Solution
8297 5
cancel
Showing results for 
Search instead for 
Did you mean: 
Alba_Machado1
4 - Data Explorer
4 - Data Explorer

I created a number field for magazine circulation sizes, the first one being 900,000. I entered 900,000 and it turned into 900000. It’s pretty standard for numbers that are higher than three digits to use a comma after every third digit from right to left. So how do I make that happen in AirTable?

2 Solutions

Accepted Solutions
Chris_Rowe1
4 - Data Explorer
4 - Data Explorer

I was able to do this by:

  1. Selecting currency for the formatting
  2. Removing the $ from the 'Currency symbol' field and leaving it blank
  3. Setting the 'Precision' field to 1 (assuming you are dealing with integers).

See Solution in Thread

This is the best work around I've seen for this obvious deficiency in Airtable's numeric formatting options, but they really need to deal with this eventually.

See Solution in Thread

5 Replies 5

Hi @Alba_Machado1 and welcome to the community!

It’s actually not common for integers to be formatted in this fashion; more of a currency thing, right?

If you need these integers expressed with more readable formatting you can create a formula field that converts them to text and inserts the commas. But this is not a slam-dunk idea; you must consider many variants - 1,000; 10,000; 100,000 - etc.

If you want to dive deep into what @W_Vann_Hall refers to as “pretty-print” formulas, here’s the thread he made about it some time ago, including a link to a sample table:

While he tried to create some mega-formulas that would handle lots of possible options, what you need probably doesn’t need to be as heavy. What’s the largest number you would need to format for your use case?

Both funny and unfortunate at the same time. Ergo - why I said…

The only difference between my experience and @W_Vann_Hall’s is I had the luxury of hindsight at his expense. :winking_face:

Chris_Rowe1
4 - Data Explorer
4 - Data Explorer

I was able to do this by:

  1. Selecting currency for the formatting
  2. Removing the $ from the 'Currency symbol' field and leaving it blank
  3. Setting the 'Precision' field to 1 (assuming you are dealing with integers).

This is the best work around I've seen for this obvious deficiency in Airtable's numeric formatting options, but they really need to deal with this eventually.