Help

Send data from Webhook to a linked colum

Topic Labels: Automations Data Integrations
334 3
cancel
Showing results for 
Search instead for 
Did you mean: 
jorgevelafoto
4 - Data Explorer
4 - Data Explorer

Hello everyone, I'm sorry if this is not the proper place to post this, actually I dont know who or where I could get help from. And sorry for my English.

I'm very new to this world so I will try to explain my problem as clear as I can.

I even set up a test table so you can see it easily. First of all, I would like my clients to fill up a form like this:

 

7e8ad527ae517faaf50d3a754963bde8.png

Then, I would like this data to be sent to my Airtable and create a new record in the column "Chosen Colection" with the chosen colection they selected in the form. The column 'collection' is linked to a price from another board, which I'll show you in the following images:

0d10bbdcf5074476bb9b551308700f52 (1).png

ad950ef45b16b6f0bc2653c871ff32b1.png

Then I made a conection in Make.com to send this data, like this:

12d28a4200b8a6171afd42abe2d2f3a4.png

Then it shows me an error like this:

0bfc263836460cf9ef7f34b6a6ac9e82.png

I'm stuck on this step and I dont know how to set it up. Please help 😞

3 Replies 3
ScottWorld
18 - Pluto
18 - Pluto

In your Make scenario, where it says "Chosen Collection", you have to turn ON the "Map" button, which will enable you to to paste in your array of collections there.

I talk more about Make arrays in this podcast episode:
https://youtu.be/sKPyG0HZCYY?list=PLqssva4liHRwHhQIpTXekG8WObEoyC2F1

p.s. If you have a budget for your project and you’d like to hire an expert Airtable consultant to help you with any of this, please feel free to contact me through my website: Airtable consulting — ScottWorld

Hello Scott, thank you for your fast reply.

I already turned on the map button but still get the same error. Could you explain what do you mean by paste in my array of collections there? I'm very new on this 😞

Thank you so much

A few things here:

1. When a field name ends in [], that means you are pasting in an array of data (instead of just one piece of data). Make sure that you are pasting in a simple array, not a complex array. I would check out my YouTube video above, which may give you some guidance on this!

2. From the error message you are receiving, it sounds like you are pasting in a complex array instead of a simple array. Check out my YouTube video above.

3. Also, very important: Be sure to turn on "Smart Links" at the bottom of the "Create A Record" module. Otherwise, you can only paste in pre-existing values into the linked record field.

4. For general Make training, I give some additional training resources in this thread.