Help

Unable to use OAuth - Error Message

Topic Labels: API
Solved
Jump to Solution
890 7
cancel
Showing results for 
Search instead for 
Did you mean: 
hannahRFP
6 - Interface Innovator
6 - Interface Innovator

I am trying to set up an OAuth for Make, as API keys are no longer available to use, and it says not to give Personal Access Tokens to third party companies.

I do not understand what the 'OAuth redirect URL' is supposed to be, at the moment I have tried the web address for Airtable https://www.airtable.com/, https://airtable.com/oauth2/v1/authorize, the web address for my Airtable base, but no luck. I'm not sure if this is the issue?

I have used the same name and have copy and pasted the client ID (deleted from the screenshot for privacy).

The error message I am getting is:

This third-party app failed to properly construct a request to Airtable: invalid client_id or mismatched redirect_uri

Please can someone help?

I have used API keys before and never had an issue, but I feel completely out of my depth with the OAuth and would prefer to use a token, but don't want to share my personal token with a 3rd party if Airtable advise against it, as it is for a company and I want to keep data secure. 

Please help if you can! Happy to provide other info if you need. 

Thanks

Screenshot 2024-02-19 at 15.26.30.png

 

Screenshot 2024-02-19 at 15.31.17.png

 

1 Solution

Accepted Solutions
TheTimeSavingCo
18 - Pluto
18 - Pluto

Ah, you don't have to fill in the Client ID or Secret bit, so you can just toggle off the advanced settings.  Just select "Airtable OAuth" as the connection type, name it like you already have, and then click Save.  A new window pops up asking you to log in to Airtable (if you're not logged in), and to select the base you want to use:

Screen Recording 2024-02-20 at 7.09.35 AM.gif

Here's the documentation

See Solution in Thread

7 Replies 7
TheTimeSavingCo
18 - Pluto
18 - Pluto

Ah, you don't have to fill in the Client ID or Secret bit, so you can just toggle off the advanced settings.  Just select "Airtable OAuth" as the connection type, name it like you already have, and then click Save.  A new window pops up asking you to log in to Airtable (if you're not logged in), and to select the base you want to use:

Screen Recording 2024-02-20 at 7.09.35 AM.gif

Here's the documentation

Thank you Adam! I was clearly overcomplicating it by adding the client ID! 

I followed the steps above and it all worked. 

Thanks again,

Hannah

JeremieP
5 - Automation Enthusiast
5 - Automation Enthusiast

Hello,

I have a similar problem (see capture). But in my case, I don't have the time to grant access from the popup window, the Code Error: 400 appears very quickly.

Any idea?

Thanks

Hmm, and so even when you try to create completely new OAuth connections it still happens?  Does it happen when you attempt to create a new connection in a new scenario as well?

Hi Adam,

yes it happens in a new scenario as well. I only have the issue with Airtable, other connections work (Dropbox, Notion...).

That's...super weird.  The only thing I can think of would be to try the entire process in a private window / different browser so that all the logins are fresh.  So:
1. Open a private window / other browser
2. Log in to Airtable
3. Log in to Make
4. Attempt the OAuth in Make again

Sorry I couldn't help much with this

It works 🙂

Thanks